summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-10-27 18:00:24 -0400
committerSam James <sam@gentoo.org>2023-10-29 03:34:24 +0000
commit51c1d02bab715ea8448c0b5e1e29b0f2def85259 (patch)
tree01f0a4cacb530a4f3e289625b989b29a21168e76 /app-text/podofo/podofo-0.10.1-r1.ebuild
parentdev-python/xarray: skip tests caused by numpy quirk/bug (diff)
downloadgentoo-51c1d02bab715ea8448c0b5e1e29b0f2def85259.tar.gz
gentoo-51c1d02bab715ea8448c0b5e1e29b0f2def85259.tar.bz2
gentoo-51c1d02bab715ea8448c0b5e1e29b0f2def85259.zip
app-text/podofo: backport patch to fix tests with optimizations
This allows us to drop the cautious use of -ffp-contract=off, since upstream has analyzed the issue and determined that it's a matter of tolerance, not an issue in the library itself, and rewritten the test a bit to not trip over this. No revbump needed. The library is the same both before and after this change, modulo some allowed compiler optimizations. https://github.com/podofo/podofo/issues/103#issuecomment-1783528312 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33572 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/podofo/podofo-0.10.1-r1.ebuild')
-rw-r--r--app-text/podofo/podofo-0.10.1-r1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/app-text/podofo/podofo-0.10.1-r1.ebuild b/app-text/podofo/podofo-0.10.1-r1.ebuild
index 01677dd282b6..9809f617298e 100644
--- a/app-text/podofo/podofo-0.10.1-r1.ebuild
+++ b/app-text/podofo/podofo-0.10.1-r1.ebuild
@@ -37,6 +37,13 @@ BDEPEND="
test? ( fontconfig? ( media-fonts/liberation-fonts ) )
"
+PATCHES=(
+ # Dome optimizations cause testsuite failures due to floating point
+ # contraction. Fixed upstream by adding tolerance to the test itself:
+ # https://github.com/podofo/podofo/issues/103
+ "${FILESDIR}"/0001-FIX-ColorTest-Fixed-test-under-linux-when-compiled-w.patch
+)
+
src_prepare() {
cmake_src_prepare
if use test; then
@@ -56,11 +63,6 @@ src_configure() {
$(cmake_use_find_package fontconfig Fontconfig)
)
- # some optimizations cause testsuite failures which may indicate
- # unsoundness with contraction. Be cautious for now. Reported
- # upstream as https://github.com/podofo/podofo/issues/103
- append-cxxflags $(test-flags-CXX -ffp-contract=off)
-
cmake_src_configure
}