summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-01-31 20:00:59 +0100
committerSebastian Pipping <sping@gentoo.org>2021-01-31 20:02:51 +0100
commit50b1b854dcc2c8edf99916c8acfc1610619adce3 (patch)
treed911ca6903ce5e3b12e470f1f4a1f6cd6807e660 /app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
parentnet-fs/smbnetfs: bump up to 0.6.3 (diff)
downloadgentoo-50b1b854dcc2c8edf99916c8acfc1610619adce3.tar.gz
gentoo-50b1b854dcc2c8edf99916c8acfc1610619adce3.tar.bz2
gentoo-50b1b854dcc2c8edf99916c8acfc1610619adce3.zip
app-text/xmlstarlet: Fix linking for lld + profile 17.1 + amd64
Closes: https://bugs.gentoo.org/729600 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild')
-rw-r--r--app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild b/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
index c2ad4628c946..81ac6ed97cce 100644
--- a/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
+++ b/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic toolchain-funcs
+inherit autotools multilib flag-o-matic toolchain-funcs
DESCRIPTION="A set of tools to transform, query, validate, and edit XML documents"
HOMEPAGE="http://xmlstar.sourceforge.net/"
@@ -21,6 +21,20 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+src_prepare() {
+ eapply_user
+
+ # We need to patch use of /usr/lib because it is a problem with
+ # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/729600)
+ # The grep sandwich acts as a regression test so that a future
+ # version bump cannot break patching without noticing
+ grep -wq _PREFIX/lib m4/xstar-check-libs.m4 || die
+ sed "s,_PREFIX/lib,_PREFIX/$(get_libdir)," -i m4/xstar-check-libs.m4 || die
+ grep -w _PREFIX/lib m4/xstar-check-libs.m4 && die
+
+ eautoreconf
+}
+
src_configure() {
append-cppflags $($(tc-getPKG_CONFIG) --cflags libxml-2.0)