summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabi Falk <gabifalk@gmx.com>2024-12-14 15:00:00 +0000
committerSam James <sam@gentoo.org>2024-12-15 16:15:37 +0000
commiteb359138a716ccef5fa2f330b648e3bd9ddcc9c6 (patch)
treea176f05db0b6392aa099db7fa8ac5712660fb451 /app-text
parentsys-process/fcron: fix build with gcc 15 (diff)
downloadgentoo-eb359138a716ccef5fa2f330b648e3bd9ddcc9c6.tar.gz
gentoo-eb359138a716ccef5fa2f330b648e3bd9ddcc9c6.tar.bz2
gentoo-eb359138a716ccef5fa2f330b648e3bd9ddcc9c6.zip
app-text/po4a: Backport upstream testsuite fixes for perl >= 5.40
Link: https://github.com/mquinson/po4a/commit/7cf7b79ee28de7e58378b225570d49fd114ff75e Link: https://github.com/mquinson/po4a/commit/28fe52651eb8096d97d6bd3a97b3168522ba5306 Closes: https://bugs.gentoo.org/938967 Signed-off-by: Gabi Falk <gabifalk@gmx.com> Closes: https://github.com/gentoo/gentoo/pull/39695 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/po4a/files/po4a-0.69-invalid-byte.patch27
-rw-r--r--app-text/po4a/files/po4a-0.69-perl5.40.patch31
-rw-r--r--app-text/po4a/files/po4a-perl5.40.patch29
-rw-r--r--app-text/po4a/po4a-0.69-r2.ebuild62
-rw-r--r--app-text/po4a/po4a-0.71-r1.ebuild (renamed from app-text/po4a/po4a-0.71.ebuild)5
-rw-r--r--app-text/po4a/po4a-0.72-r1.ebuild (renamed from app-text/po4a/po4a-0.72.ebuild)5
-rw-r--r--app-text/po4a/po4a-0.73-r1.ebuild57
7 files changed, 214 insertions, 2 deletions
diff --git a/app-text/po4a/files/po4a-0.69-invalid-byte.patch b/app-text/po4a/files/po4a-0.69-invalid-byte.patch
new file mode 100644
index 000000000000..f1f230a95b48
--- /dev/null
+++ b/app-text/po4a/files/po4a-0.69-invalid-byte.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/938967
+https://github.com/mquinson/po4a/commit/7cf7b79ee28de7e58378b225570d49fd114ff75e.patch
+
+From 7cf7b79ee28de7e58378b225570d49fd114ff75e Mon Sep 17 00:00:00 2001
+From: Jan Palus <jpalus@fastmail.com>
+Date: Mon, 3 Jul 2023 14:56:04 +0200
+Subject: [PATCH] SGML: replace invalid byte (0xa0) in comment with space
+ (0x20)
+
+Fixes #428
+---
+ lib/Locale/Po4a/Sgml.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/Locale/Po4a/Sgml.pm b/lib/Locale/Po4a/Sgml.pm
+index 39dd66f2..d02f269d 100644
+--- a/lib/Locale/Po4a/Sgml.pm
++++ b/lib/Locale/Po4a/Sgml.pm
+@@ -773,7 +773,7 @@ sub parse_file {
+ while ( $origfile =~ /^(.*?)&$key(;.*$|[^-_:.A-Za-z0-9].*$|$)/s ) {
+
+ # Since we will include a new file, we
+- # must do a new round of substitutions.
++ # must do a new round of substitutions.
+ $dosubstitution = 1;
+ my ( $begin, $end ) = ( $1, $2 );
+ $end = "" unless ( defined $end );
diff --git a/app-text/po4a/files/po4a-0.69-perl5.40.patch b/app-text/po4a/files/po4a-0.69-perl5.40.patch
new file mode 100644
index 000000000000..8c7d7d8573e8
--- /dev/null
+++ b/app-text/po4a/files/po4a-0.69-perl5.40.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/938967
+https://github.com/mquinson/po4a/commit/28fe52651eb8096d97d6bd3a97b3168522ba5306 (backport)
+
+From 45c835a04a388940c627f0c6b8c26554c0ee2b14 Mon Sep 17 00:00:00 2001
+From: Martin Quinson <martin.quinson@ens-rennes.fr>
+Date: Fri, 12 Jul 2024 10:21:34 +0200
+Subject: [PATCH] Fix failures with DynaLoader on Perl 5.40
+
+Thanks to dstoecker for the patch provided in the OpenSuse package,
+and to ana for pointing me to it.
+
+Fixes https://github.com/mquinson/po4a/issues/508
+
+(cherry picked from commit 28fe52651eb8096d97d6bd3a97b3168522ba5306)
+---
+ lib/Locale/Po4a/TransTractor.pm | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/lib/Locale/Po4a/TransTractor.pm b/lib/Locale/Po4a/TransTractor.pm
+index b83dd25b..68296cb1 100644
+--- a/lib/Locale/Po4a/TransTractor.pm
++++ b/lib/Locale/Po4a/TransTractor.pm
+@@ -5,6 +5,8 @@ require Exporter;
+ package Locale::Po4a::TransTractor;
+ use DynaLoader;
+
++sub import { }
++
+ use 5.006;
+ use strict;
+ use warnings;
diff --git a/app-text/po4a/files/po4a-perl5.40.patch b/app-text/po4a/files/po4a-perl5.40.patch
new file mode 100644
index 000000000000..221e45f79198
--- /dev/null
+++ b/app-text/po4a/files/po4a-perl5.40.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/938967
+https://github.com/mquinson/po4a/commit/28fe52651eb8096d97d6bd3a97b3168522ba5306.patch
+
+From 28fe52651eb8096d97d6bd3a97b3168522ba5306 Mon Sep 17 00:00:00 2001
+From: Martin Quinson <martin.quinson@ens-rennes.fr>
+Date: Fri, 12 Jul 2024 10:21:34 +0200
+Subject: [PATCH] Fix failures with DynaLoader on Perl 5.40
+
+Thanks to dstoecker for the patch provided in the OpenSuse package,
+and to ana for pointing me to it.
+
+Fixes https://github.com/mquinson/po4a/issues/508
+---
+ lib/Locale/Po4a/TransTractor.pm | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/lib/Locale/Po4a/TransTractor.pm b/lib/Locale/Po4a/TransTractor.pm
+index 7bf59ef05..7b6112433 100644
+--- a/lib/Locale/Po4a/TransTractor.pm
++++ b/lib/Locale/Po4a/TransTractor.pm
+@@ -5,6 +5,8 @@ require Exporter;
+ package Locale::Po4a::TransTractor;
+ use DynaLoader;
+
++sub import { }
++
+ use 5.16.0;
+ use strict;
+ use warnings;
diff --git a/app-text/po4a/po4a-0.69-r2.ebuild b/app-text/po4a/po4a-0.69-r2.ebuild
new file mode 100644
index 000000000000..836210177e04
--- /dev/null
+++ b/app-text/po4a/po4a-0.69-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="ace af ar ca cs da de eo es et eu fr hr hu id it ja ka kn ko nb nl pl pt pt_BR ru sl sr_Cyrl sv uk vi zh_CN zh_HK zh_Hant"
+
+inherit perl-module plocale
+
+DESCRIPTION="Tools to ease the translation of documentation"
+HOMEPAGE="https://po4a.org/"
+SRC_URI="https://github.com/mquinson/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/opensp
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/Pod-Parser
+ dev-perl/SGMLSpm
+ dev-perl/Syntax-Keyword-Try
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N
+ dev-perl/Unicode-LineBreak
+ dev-perl/YAML-Tiny
+ sys-devel/gettext"
+DEPEND="${RDEPEND}"
+BDEPEND="app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-perl/Module-Build
+ sys-devel/gettext
+ test? (
+ app-text/docbook-sgml-dtd:4.1
+ dev-perl/Test-Pod
+ virtual/latex-base
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-man.patch
+ "${FILESDIR}"/${P}-xmlcatalog.patch
+ "${FILESDIR}"/${P}-perl5.40.patch # bug #938967
+ # The perl5.40 patch triggers:
+ # XX Update po/bin/po4a.pot
+ # xgettext: Comment at or before ../../lib/Locale/Po4a/Sgml.pm:776 is not UTF-8 encoded.
+ "${FILESDIR}"/${P}-invalid-byte.patch
+)
+
+DIST_TEST="do"
+
+src_prepare() {
+ plocale_find_changes "${S}/po/bin" '' '.po'
+
+ rm_locale() {
+ PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
+ }
+ plocale_for_each_disabled_locale rm_locale
+
+ perl-module_src_prepare
+}
diff --git a/app-text/po4a/po4a-0.71.ebuild b/app-text/po4a/po4a-0.71-r1.ebuild
index 18c3ed6fdf91..0d85bd31b9c0 100644
--- a/app-text/po4a/po4a-0.71.ebuild
+++ b/app-text/po4a/po4a-0.71-r1.ebuild
@@ -38,7 +38,10 @@ BDEPEND="app-text/docbook-xml-dtd:4.1.2
virtual/latex-base
)"
-PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-man.patch
+ "${FILESDIR}"/${PN}-perl5.40.patch # bug #938967
+)
DIST_TEST="do"
diff --git a/app-text/po4a/po4a-0.72.ebuild b/app-text/po4a/po4a-0.72-r1.ebuild
index 18c3ed6fdf91..0d85bd31b9c0 100644
--- a/app-text/po4a/po4a-0.72.ebuild
+++ b/app-text/po4a/po4a-0.72-r1.ebuild
@@ -38,7 +38,10 @@ BDEPEND="app-text/docbook-xml-dtd:4.1.2
virtual/latex-base
)"
-PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-man.patch
+ "${FILESDIR}"/${PN}-perl5.40.patch # bug #938967
+)
DIST_TEST="do"
diff --git a/app-text/po4a/po4a-0.73-r1.ebuild b/app-text/po4a/po4a-0.73-r1.ebuild
new file mode 100644
index 000000000000..63e8819d32c6
--- /dev/null
+++ b/app-text/po4a/po4a-0.73-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="ace af ar ca cs da de eo es et eu fr hr hu id it ja ka kn ko nb nl pl pt pt_BR ru sl sr sr_Cyrl sv uk vi zh_Hans zh_Hant"
+
+inherit perl-module plocale
+
+DESCRIPTION="Tools to ease the translation of documentation"
+HOMEPAGE="https://po4a.org/"
+SRC_URI="https://github.com/mquinson/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/opensp
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/Pod-Parser
+ dev-perl/SGMLSpm
+ dev-perl/Syntax-Keyword-Try
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N
+ dev-perl/Unicode-LineBreak
+ dev-perl/YAML-Tiny
+ sys-devel/gettext"
+DEPEND="${RDEPEND}"
+BDEPEND="app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-perl/Module-Build
+ sys-devel/gettext
+ test? (
+ app-text/docbook-sgml-dtd:4.1
+ dev-perl/Test-Pod
+ virtual/latex-base
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-man.patch
+ "${FILESDIR}"/${PN}-perl5.40.patch # bug #938967
+)
+
+DIST_TEST="do"
+
+src_prepare() {
+ plocale_find_changes "${S}/po/bin" '' '.po'
+
+ rm_locale() {
+ PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
+ }
+ plocale_for_each_disabled_locale rm_locale
+
+ perl-module_src_prepare
+}