summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 18:33:23 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:52 +0200
commita90b8d8edc0bdd86bbde8907cd1239ff6edfbcbf (patch)
treeb85318251b03c3a2ac88648308d5ca2beeec2c9a /app-vim
parentapp-vim/wikipedia-syntax: EAPI8 bump (diff)
downloadgentoo-a90b8d8edc0bdd86bbde8907cd1239ff6edfbcbf.tar.gz
gentoo-a90b8d8edc0bdd86bbde8907cd1239ff6edfbcbf.tar.bz2
gentoo-a90b8d8edc0bdd86bbde8907cd1239ff6edfbcbf.zip
app-vim/xquery-syntax: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/xquery-syntax/xquery-syntax-0.1-r3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/xquery-syntax/xquery-syntax-0.1-r3.ebuild b/app-vim/xquery-syntax/xquery-syntax-0.1-r3.ebuild
new file mode 100644
index 000000000000..a1bc0756a5d8
--- /dev/null
+++ b/app-vim/xquery-syntax/xquery-syntax-0.1-r3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: XQuery syntax highlighting"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=803"
+
+LICENSE="vim.org"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for XQuery files."
+
+src_prepare() {
+ default
+ # use hi def link. Bug #101788, bug #101804.
+ sed -i -e 's,^hi\(ghlight\)\? link,hi def link,' syntax/xquery.vim \
+ || die "sed failed"
+}