summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-06-01 18:21:17 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-06-01 18:21:17 +0200
commitfc051412f79dc7cd95683488eccf41cc2fa28382 (patch)
tree12763f0e9a9bcd82237ef94c0899621ac6be9b3c /dev-ada/aunit/aunit-2021.ebuild
parentdev-vcs/mercurial: Stabilize 5.8 arm, #792042 (diff)
downloadgentoo-fc051412f79dc7cd95683488eccf41cc2fa28382.tar.gz
gentoo-fc051412f79dc7cd95683488eccf41cc2fa28382.tar.bz2
gentoo-fc051412f79dc7cd95683488eccf41cc2fa28382.zip
dev-ada/aunit: bump to 2021
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada/aunit/aunit-2021.ebuild')
-rw-r--r--dev-ada/aunit/aunit-2021.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ada/aunit/aunit-2021.ebuild b/dev-ada/aunit/aunit-2021.ebuild
new file mode 100644
index 000000000000..6dd2c2857e24
--- /dev/null
+++ b/dev-ada/aunit/aunit-2021.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ADA_COMPAT=( gnat_201{6..9} gnat_202{0..1} )
+inherit ada multiprocessing
+
+MYP=${P}-${PV}0518-19DC5-src
+
+DESCRIPTION="Ada unit testing framework"
+HOMEPAGE="http://libre.adacore.com/tools/aunit/"
+SRC_URI="https://community.download.adacore.com/v1/c8eadafc40c016859e127cd0e82411fcd8f3e749?filename=${MYP}.tar.gz
+ -> ${MYP}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${ADA_DEPS}"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+S="${WORKDIR}"/${MYP}
+
+PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
+
+src_compile() {
+ emake GPRBUILD="gprbuild -j$(makeopts_jobs) -v"
+}
+
+src_install() {
+ emake INSTALL="${D}"/usr install
+ einstalldocs
+ mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${PF}/ || die
+ rmdir "${D}"/usr/share/doc/${PN} || die
+ mv "${D}"/usr/share/examples/${PN} "${D}"/usr/share/doc/${PF}/examples || die
+ rmdir "${D}"/usr/share/examples || die
+ rm -r "${D}"/usr/share/gpr/manifests || die
+}
+
+src_test() {
+ emake PROJECT_PATH_ARG="ADA_PROJECT_PATH=$(pwd)/lib/gnat" -C test
+}