summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2019-06-08 18:27:02 -0400
committerMichał Górny <mgorny@gentoo.org>2019-06-15 22:29:28 +0200
commite58c0ab35c35b4de684f86137e432efba6592080 (patch)
treeec1b0c76883af5a9e6c4f451a9120e2915aafc58 /dev-cpp/gtest/gtest-9999.ebuild
parentdev-cpp/gtest: Update patch for gtest-9999 (diff)
downloadgentoo-e58c0ab35c35b4de684f86137e432efba6592080.tar.gz
gentoo-e58c0ab35c35b4de684f86137e432efba6592080.tar.bz2
gentoo-e58c0ab35c35b4de684f86137e432efba6592080.zip
dev-cpp/gtest: Update to 1.9.0_pre20190607
Latest dev-libs/protobuf-3.8.0 is going to need the INSTANTIATE_TEST_SUITE_P macro which is defined in upstream master branch. Also, fixes for building with gcc-9 have been included upstream so this kills two bugs. Reported-by: Toralf Förster <toralf@gentoo.org> Closes: https://bugs.gentoo.org/687086 Reported-by: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> Tested-by: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> Closes: https://bugs.gentoo.org/687606 Closes: https://github.com/gentoo/gentoo/pull/12222 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp/gtest/gtest-9999.ebuild')
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index 98ce51d82aec..685acf50cd67 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -12,9 +12,14 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/google/googletest"
else
- SRC_URI="https://github.com/google/googletest/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ if [[ -z ${GOOGLETEST_COMMIT} ]]; then
+ MY_PV=release-${PV}
+ else
+ MY_PV=${GOOGLETEST_COMMIT}
+ fi
+ SRC_URI="https://github.com/google/googletest/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
- S="${WORKDIR}"/googletest-release-${PV}
+ S="${WORKDIR}"/googletest-${MY_PV}
fi
DESCRIPTION="Google C++ Testing Framework"