summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-01-22 20:06:16 -0600
committerMatthias Maier <tamiko@gentoo.org>2023-01-22 20:06:16 -0600
commitf191cdee2c217ad2a0af7f37459c438614650472 (patch)
treeb11d59593adb64ba20cd3ddc4fbc518f3d07d5e0 /dev-cpp/muParser/muParser-2.3.3-r2.ebuild
parentdev-cpp/muParser: drop 2.3.2-r1, 2.3.3 (diff)
downloadgentoo-f191cdee2c217ad2a0af7f37459c438614650472.tar.gz
gentoo-f191cdee2c217ad2a0af7f37459c438614650472.tar.bz2
gentoo-f191cdee2c217ad2a0af7f37459c438614650472.zip
dev-cpp/muParser: Remove USE=wchar
Unfortunately, this innocent looking USE flag incurs a silent ABI change that let's all its reverse dependencies fail. A number of the reverse dependencies of muParser already set muParser[-wchar] explicitly and the rest is probably also not compiling. Thus, remove the use flag. If someone wants to have wchar_t support in muParser then a proper solution would be to slot the package and install both ABI variants simultaneously. Closes: https://bugs.gentoo.org/880133 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-cpp/muParser/muParser-2.3.3-r2.ebuild')
-rw-r--r--dev-cpp/muParser/muParser-2.3.3-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-cpp/muParser/muParser-2.3.3-r2.ebuild b/dev-cpp/muParser/muParser-2.3.3-r2.ebuild
new file mode 100644
index 000000000000..cab8c4f6caf3
--- /dev/null
+++ b/dev-cpp/muParser/muParser-2.3.3-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+# The upstream tag is v2.3.3-1 instead of v2.3.3
+suffix="-1"
+
+DESCRIPTION="Library for parsing mathematical expressions"
+HOMEPAGE="https://beltoforion.de/en/muparser/"
+SRC_URI="https://github.com/beltoforion/muparser/archive/refs/tags/v${PV}${suffix}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/muparser-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc openmp test"
+RESTRICT="!test? ( test )"
+
+S="${S}${suffix}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_OPENMP=$(usex openmp)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_src_compile test
+}