summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-03-20 10:38:31 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-03-20 10:38:31 +0000
commit1423841eb6ef3c5fa2363cc38e04665ef4e06fe9 (patch)
treeccaf40869c153758108057b1f58bdcb9ae7dc1df /dev-cpp/sdbus-c++/files
parentnet-im/rocketchat-desktop-bin: drop 3.7.9 (diff)
downloadgentoo-1423841eb6ef3c5fa2363cc38e04665ef4e06fe9.tar.gz
gentoo-1423841eb6ef3c5fa2363cc38e04665ef4e06fe9.tar.bz2
gentoo-1423841eb6ef3c5fa2363cc38e04665ef4e06fe9.zip
dev-cpp/sdbus-c++: New package
Including older 0.9.0 version for msalsdk-dbusclient. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-cpp/sdbus-c++/files')
-rw-r--r--dev-cpp/sdbus-c++/files/sdbus-c++-gtest-1.11.patch58
-rw-r--r--dev-cpp/sdbus-c++/files/sdbus-c++-static-libsystemd.patch10
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-cpp/sdbus-c++/files/sdbus-c++-gtest-1.11.patch b/dev-cpp/sdbus-c++/files/sdbus-c++-gtest-1.11.patch
new file mode 100644
index 000000000000..e6d3622ee11f
--- /dev/null
+++ b/dev-cpp/sdbus-c++/files/sdbus-c++-gtest-1.11.patch
@@ -0,0 +1,58 @@
+From 7f437a6e06d2ec3abd3e2fd1101ab6aab386bc44 Mon Sep 17 00:00:00 2001
+From: Stanislav Angelovic <stanislav.angelovic@siemens.com>
+Date: Thu, 27 Jan 2022 13:38:19 +0100
+Subject: [PATCH] fix(tests): printer for std::chrono in googletest v1.11.0
+
+---
+ tests/CMakeLists.txt | 2 +-
+ tests/integrationtests/Defs.h | 22 ++++++++++------------
+ 2 files changed, 11 insertions(+), 13 deletions(-)
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index fbf198c..ec42e55 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -19,7 +19,7 @@ if (NOT TARGET GTest::gmock)
+ if (NOT TARGET GTest::gmock)
+ include(FetchContent)
+
+- message("Fetching googletest...")
++ message("Fetching googletest v${GOOGLETEST_VERSION}...")
+ FetchContent_Declare(googletest
+ GIT_REPOSITORY ${GOOGLETEST_GIT_REPO}
+ GIT_TAG release-${GOOGLETEST_VERSION}
+diff --git a/tests/integrationtests/Defs.h b/tests/integrationtests/Defs.h
+index 2f129a4..2bfc7c9 100644
+--- a/tests/integrationtests/Defs.h
++++ b/tests/integrationtests/Defs.h
+@@ -56,20 +56,18 @@ const bool DEFAULT_BLOCKING_VALUE{true};
+
+ constexpr const double DOUBLE_VALUE{3.24L};
+
+-/** Duration stream operator for human readable gtest value output.
+- *
+- * Note that the conversion to double is lossy if the input type has 64 or more bits.
+- * This is ok for our integration tests because they don't have very
+- * accurate timing requirements.
+- *
+- * @return human readable duration in seconds
+- */
++}}
++
++namespace testing::internal {
++
++// Printer for std::chrono::duration types.
++// This is a workaround, since it's not a good thing to add this to std namespace.
+ template< class Rep, class Period >
+-static std::ostream& operator<<(std::ostream& os, const std::chrono::duration<Rep, Period>& d)
+-{
++void PrintTo(const ::std::chrono::duration<Rep, Period>& d, ::std::ostream* os) {
+ auto seconds = std::chrono::duration_cast<std::chrono::duration<double>>(d);
+- return os << seconds.count() << " s";
++ *os << seconds.count() << "s";
++}
++
+ }
+-}}
+
+ #endif /* SDBUS_CPP_INTEGRATIONTESTS_DEFS_H_ */
diff --git a/dev-cpp/sdbus-c++/files/sdbus-c++-static-libsystemd.patch b/dev-cpp/sdbus-c++/files/sdbus-c++-static-libsystemd.patch
new file mode 100644
index 000000000000..d6f018fda175
--- /dev/null
+++ b/dev-cpp/sdbus-c++/files/sdbus-c++-static-libsystemd.patch
@@ -0,0 +1,10 @@
+systemd does not include pkg-config dependencies for static linking.
+
+diff -Naur a/src/libsystemd/libsystemd.pc.in b/src/libsystemd/libsystemd.pc.in
+--- a/src/libsystemd/libsystemd.pc.in 2022-01-18 11:35:43.000000000 +0000
++++ b/src/libsystemd/libsystemd.pc.in 2022-03-05 21:24:47.139338880 +0000
+@@ -18,3 +18,4 @@
+ Version: {{PROJECT_VERSION}}
+ Libs: -L${libdir} -lsystemd
+ Cflags: -I${includedir}
++Requires: libcap