summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-14 05:42:56 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-14 06:07:49 -0400
commit76c715b4aeea02b52e97879d0d16e33cc89037e4 (patch)
treedbe9edf80508f5ca679fc29d0c6de237138d635b /dev-cpp/simpleini/files
parentx11-terms/kitty: Backport fix for musl 1.2.4 (diff)
downloadgentoo-76c715b4aeea02b52e97879d0d16e33cc89037e4.tar.gz
gentoo-76c715b4aeea02b52e97879d0d16e33cc89037e4.tar.bz2
gentoo-76c715b4aeea02b52e97879d0d16e33cc89037e4.zip
dev-cpp/simpleini: add 4.20
Upstream added a CMakeLists but it does not really do anything for us (no install target, no tests handling, no .cmake to install), and is intended for in-source usage. So no changes in that regard. However the normal Makefiles did get some improvements, there's an install target and tests' now use pkg-config to find gtest. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp/simpleini/files')
-rw-r--r--dev-cpp/simpleini/files/simpleini-4.20-pkgconfig-var.patch8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-cpp/simpleini/files/simpleini-4.20-pkgconfig-var.patch b/dev-cpp/simpleini/files/simpleini-4.20-pkgconfig-var.patch
new file mode 100644
index 000000000000..1250a01f3ca2
--- /dev/null
+++ b/dev-cpp/simpleini/files/simpleini-4.20-pkgconfig-var.patch
@@ -0,0 +1,8 @@
+Use $(PKG_CONFIG), and also avoid repeating the calls for every objects.
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -2,2 +2,2 @@
+-CXXFLAGS+=-Wall -std=c++14 `pkg-config --cflags gtest_main`
+-LDFLAGS+=`pkg-config --libs gtest_main`
++CXXFLAGS:=-Wall -std=c++14 $(shell $(PKG_CONFIG) --cflags gtest_main) $(CXXFLAGS)
++LDFLAGS:=$(LDFLAGS) $(shell $(PKG_CONFIG) --libs gtest_main)