summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-01-27 19:49:15 +0000
committerSam James <sam@gentoo.org>2024-01-28 22:13:41 +0000
commit02d9351d758b8e0e604e347f6068bcbb3c8f8f03 (patch)
tree1068dfae0b8d62ad4f19eca1cc51f63bea996de8 /dev-cpp
parentapp-admin/conky: wire up tests (diff)
downloadgentoo-02d9351d758b8e0e604e347f6068bcbb3c8f8f03.tar.gz
gentoo-02d9351d758b8e0e604e347f6068bcbb3c8f8f03.tar.bz2
gentoo-02d9351d758b8e0e604e347f6068bcbb3c8f8f03.zip
dev-cpp/tbb: fix build with ld.lld (error: version script assignment of 'local' to symbol ...)
Closes: https://bugs.gentoo.org/912210 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35048 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/tbb/tbb-2020.3.ebuild7
-rw-r--r--dev-cpp/tbb/tbb-2021.10.0.ebuild7
-rw-r--r--dev-cpp/tbb/tbb-2021.11.0.ebuild7
-rw-r--r--dev-cpp/tbb/tbb-2021.5.0-r1.ebuild10
-rw-r--r--dev-cpp/tbb/tbb-2021.7.0-r1.ebuild7
-rw-r--r--dev-cpp/tbb/tbb-2021.7.0.ebuild5
-rw-r--r--dev-cpp/tbb/tbb-2021.8.0.ebuild7
-rw-r--r--dev-cpp/tbb/tbb-2021.9.0.ebuild7
8 files changed, 42 insertions, 15 deletions
diff --git a/dev-cpp/tbb/tbb-2020.3.ebuild b/dev-cpp/tbb/tbb-2020.3.ebuild
index 27479b3e46af..36dc24e44018 100644
--- a/dev-cpp/tbb/tbb-2020.3.ebuild
+++ b/dev-cpp/tbb/tbb-2020.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic multilib-minimal multilib toolchain-funcs
+inherit flag-o-matic multilib-minimal multilib multibuild toolchain-funcs
PV1="$(ver_cut 1)"
PV2="$(ver_cut 2)"
@@ -40,6 +40,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # Workaround for bug #912210
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
# pc files are for debian and fedora compatibility
# some deps use them
cat <<-EOF > ${PN}.pc.template
diff --git a/dev-cpp/tbb/tbb-2021.10.0.ebuild b/dev-cpp/tbb/tbb-2021.10.0.ebuild
index 2e11233b7583..3d0e05e45514 100644
--- a/dev-cpp/tbb/tbb-2021.10.0.ebuild
+++ b/dev-cpp/tbb/tbb-2021.10.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
DESCRIPTION="High level abstract threading library"
HOMEPAGE="https://github.com/oneapi-src/oneTBB"
@@ -27,6 +27,9 @@ PATCHES=(
)
src_prepare() {
+ # Workaround for bug #912210
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
# Has an #error to force compilation as C but links with C++ library, dies
# with GLIBCXX_ASSERTIONS as a result.
sed -i -e '/tbb_add_c_test(SUBDIR tbbmalloc NAME test_malloc_pure_c DEPENDENCIES TBB::tbbmalloc)/d' test/CMakeLists.txt || die
diff --git a/dev-cpp/tbb/tbb-2021.11.0.ebuild b/dev-cpp/tbb/tbb-2021.11.0.ebuild
index 2e11233b7583..3ac69c080835 100644
--- a/dev-cpp/tbb/tbb-2021.11.0.ebuild
+++ b/dev-cpp/tbb/tbb-2021.11.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
DESCRIPTION="High level abstract threading library"
HOMEPAGE="https://github.com/oneapi-src/oneTBB"
@@ -35,6 +35,9 @@ src_prepare() {
}
src_configure() {
+ # Workaround for bug #912210
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
local mycmakeargs=(
-DTBB_TEST=$(usex test)
-DTBB_ENABLE_IPO=OFF
diff --git a/dev-cpp/tbb/tbb-2021.5.0-r1.ebuild b/dev-cpp/tbb/tbb-2021.5.0-r1.ebuild
index edfd4bd37ec7..adb066b4c2d9 100644
--- a/dev-cpp/tbb/tbb-2021.5.0-r1.ebuild
+++ b/dev-cpp/tbb/tbb-2021.5.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
DESCRIPTION="High level abstract threading library"
HOMEPAGE="https://github.com/oneapi-src/oneTBB"
@@ -39,6 +39,12 @@ PATCHES=(
)
src_configure() {
+ # Workaround for bug #912210
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
+ # Workaround for bug #912210
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
local mycmakeargs=(
-DTBB_TEST=$(usex test)
-DTBB_ENABLE_IPO=OFF
diff --git a/dev-cpp/tbb/tbb-2021.7.0-r1.ebuild b/dev-cpp/tbb/tbb-2021.7.0-r1.ebuild
index 4263e849f7d0..dd9c26717c7e 100644
--- a/dev-cpp/tbb/tbb-2021.7.0-r1.ebuild
+++ b/dev-cpp/tbb/tbb-2021.7.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
DESCRIPTION="High level abstract threading library"
HOMEPAGE="https://github.com/oneapi-src/oneTBB"
@@ -27,6 +27,9 @@ PATCHES=(
)
src_configure() {
+ # Workaround for bug #912210
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
local mycmakeargs=(
-DTBB_TEST=$(usex test)
-DTBB_ENABLE_IPO=OFF
diff --git a/dev-cpp/tbb/tbb-2021.7.0.ebuild b/dev-cpp/tbb/tbb-2021.7.0.ebuild
index 5f2737037ddb..972e90e1702f 100644
--- a/dev-cpp/tbb/tbb-2021.7.0.ebuild
+++ b/dev-cpp/tbb/tbb-2021.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,6 +23,9 @@ DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_configure() {
+ # Workaround for bug #912210
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
# bug #872287
filter-flags -D_GLIBCXX_ASSERTIONS
append-cppflags -U_GLIBCXX_ASSERTIONS
diff --git a/dev-cpp/tbb/tbb-2021.8.0.ebuild b/dev-cpp/tbb/tbb-2021.8.0.ebuild
index 7fdc1d716762..9b77bc83b8e5 100644
--- a/dev-cpp/tbb/tbb-2021.8.0.ebuild
+++ b/dev-cpp/tbb/tbb-2021.8.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
DESCRIPTION="High level abstract threading library"
HOMEPAGE="https://github.com/oneapi-src/oneTBB"
@@ -36,6 +36,9 @@ src_prepare() {
}
src_configure() {
+ # Workaround for bug #912210
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
local mycmakeargs=(
-DTBB_TEST=$(usex test)
-DTBB_ENABLE_IPO=OFF
diff --git a/dev-cpp/tbb/tbb-2021.9.0.ebuild b/dev-cpp/tbb/tbb-2021.9.0.ebuild
index 2e24080c2a1e..2a0013ba8bb3 100644
--- a/dev-cpp/tbb/tbb-2021.9.0.ebuild
+++ b/dev-cpp/tbb/tbb-2021.9.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
DESCRIPTION="High level abstract threading library"
HOMEPAGE="https://github.com/oneapi-src/oneTBB"
@@ -35,6 +35,9 @@ src_prepare() {
}
src_configure() {
+ # Workaround for bug #912210
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
local mycmakeargs=(
-DTBB_TEST=$(usex test)
-DTBB_ENABLE_IPO=OFF