summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-06-14 12:23:38 +0100
committerMarek Szuba <marecki@gentoo.org>2024-06-14 14:33:37 +0100
commit5b0462d90bbb25913a0e65d3790c15b8a5a9a39a (patch)
tree8e957fb045de3c025310ceff316f8443d30cc357 /dev-cpp
parentdev-cpp/clhpp: drop 2023.04.17 (diff)
downloadgentoo-5b0462d90bbb25913a0e65d3790c15b8a5a9a39a.tar.gz
gentoo-5b0462d90bbb25913a0e65d3790c15b8a5a9a39a.tar.bz2
gentoo-5b0462d90bbb25913a0e65d3790c15b8a5a9a39a.zip
dev-cpp/benchmark: drop 1.8.3
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/benchmark/benchmark-1.8.3.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.8.3.ebuild b/dev-cpp/benchmark/benchmark-1.8.3.ebuild
deleted file mode 100644
index 5112ab78a558..000000000000
--- a/dev-cpp/benchmark/benchmark-1.8.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="A microbenchmark support library"
-HOMEPAGE="https://github.com/google/benchmark"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv x86"
-IUSE="debug doc test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="doc? ( app-text/doxygen )
- test? ( >=dev-cpp/gtest-1.11.0 )"
-PATCHES=( "${FILESDIR}/${PN}-1.8.3-fix-32bit-test.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
- -DBENCHMARK_ENABLE_DOXYGEN=$(usex doc)
- -DBENCHMARK_ENABLE_GTEST_TESTS=$(usex test)
- -DBENCHMARK_ENABLE_TESTING=$(usex test)
- -DBENCHMARK_ENABLE_WERROR=OFF
- -DBENCHMARK_USE_BUNDLED_GTEST=OFF
- )
-
- use debug || append-cppflags -DNDEBUG
-
- cmake_src_configure
-}