summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2024-08-30 17:29:17 +0200
committerJakov Smolić <jsmolic@gentoo.org>2024-08-30 17:29:17 +0200
commitb0d2d6963072637cb600ef541013f4bc6b562ebc (patch)
treefd19a71af34894a0747b8edd630841da402fdbca /dev-cpp
parentdev-cpp/aixlog: drop 9999 (diff)
downloadgentoo-b0d2d6963072637cb600ef541013f4bc6b562ebc.tar.gz
gentoo-b0d2d6963072637cb600ef541013f4bc6b562ebc.tar.bz2
gentoo-b0d2d6963072637cb600ef541013f4bc6b562ebc.zip
dev-cpp/aixlog: update EAPI 7 -> 8
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/aixlog/aixlog-1.5.0-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-cpp/aixlog/aixlog-1.5.0-r1.ebuild b/dev-cpp/aixlog/aixlog-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..4bac816603bb
--- /dev/null
+++ b/dev-cpp/aixlog/aixlog-1.5.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Header-only C++ logging library"
+HOMEPAGE="https://github.com/badaix/aixlog"
+SRC_URI="https://github.com/badaix/aixlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+ cmake_src_configure
+}