summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-31 22:57:45 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-31 23:14:18 -0400
commitf5c6d1a0307edb48ce6241aaac659946edf345ba (patch)
tree24ce8e7a4e6ca6222a56e1e3d55bca991b38a7f9 /dev-cpp
parentsci-libs/ginkgo: mark as LTO-unsafe, strict-aliasing unsafe (diff)
downloadgentoo-f5c6d1a0307edb48ce6241aaac659946edf345ba.tar.gz
gentoo-f5c6d1a0307edb48ce6241aaac659946edf345ba.tar.bz2
gentoo-f5c6d1a0307edb48ce6241aaac659946edf345ba.zip
dev-cpp/ctemplate: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/924637 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-cpp/ctemplate/ctemplate-2.4.ebuild b/dev-cpp/ctemplate/ctemplate-2.4.ebuild
index 1028e3972a78..4cbee4fbcc2e 100644
--- a/dev-cpp/ctemplate/ctemplate-2.4.ebuild
+++ b/dev-cpp/ctemplate/ctemplate-2.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit autotools elisp-common python-any-r1
+inherit autotools elisp-common flag-o-matic python-any-r1
DESCRIPTION="A simple but powerful template language for C++"
HOMEPAGE="https://github.com/olafvdspek/ctemplate"
@@ -33,6 +33,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/924637
+ # https://github.com/OlafvdSpek/ctemplate/issues/157
+ filter-lto
+
econf $(use_enable static-libs static)
}