summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-05-07 21:50:11 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-05-07 21:50:11 +0900
commit0cab7bd32a6042bf81e193e5ccaccb7bcbb84aed (patch)
treeaa3f414c2cdb5ff6eae363a0a42be27745361448 /dev-db/qdbm
parentapp-text/namazu: update to EAPI 8 (diff)
downloadgentoo-0cab7bd32a6042bf81e193e5ccaccb7bcbb84aed.tar.gz
gentoo-0cab7bd32a6042bf81e193e5ccaccb7bcbb84aed.tar.bz2
gentoo-0cab7bd32a6042bf81e193e5ccaccb7bcbb84aed.zip
dev-db/qdbm: fix build with USE=ruby
Closes: https://bugs.gentoo.org/926167 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-db/qdbm')
-rw-r--r--dev-db/qdbm/files/qdbm-ruby.patch81
-rw-r--r--dev-db/qdbm/qdbm-1.8.78-r5.ebuild (renamed from dev-db/qdbm/qdbm-1.8.78-r4.ebuild)3
2 files changed, 83 insertions, 1 deletions
diff --git a/dev-db/qdbm/files/qdbm-ruby.patch b/dev-db/qdbm/files/qdbm-ruby.patch
new file mode 100644
index 000000000000..8b1a946d8d8c
--- /dev/null
+++ b/dev-db/qdbm/files/qdbm-ruby.patch
@@ -0,0 +1,81 @@
+--- a/ruby/curia/extconf.rb
++++ b/ruby/curia/extconf.rb
+@@ -2,10 +2,9 @@
+
+ dir_config("curia")
+
+-home = ENV['HOME']
+-$CFLAGS = "-I. -I../.. -I#{home}/include -I/usr/local/include"
+-$LDFLAGS = "-L../.. -L#{home}/lib -L/usr/local/lib"
+-$LIBS = "-L../.. -L#{home}/lib -L/usr/local/lib"
++$CFLAGS << " -I../.. " << ENV["CFLAGS"]
++$LDFLAGS << " -L../.. " << ENV["LDFLAGS"]
++$LIBS << " -L../.."
+
+ have_library("c", "main")
+ have_library("pthread", "main")
+--- a/ruby/curia/mod_curia.c
++++ b/ruby/curia/mod_curia.c
+@@ -84,7 +84,7 @@
+ *************************************************************************************************/
+
+
+-Init_mod_curia(){
++void Init_mod_curia(void){
+ crinit();
+ ccuriaerror = rb_define_class("CuriaError", rb_eStandardError);
+ ccuriaerror_ENOERR = rb_define_class("CuriaError_ENOERR", ccuriaerror);
+--- a/ruby/depot/extconf.rb
++++ b/ruby/depot/extconf.rb
+@@ -2,10 +2,9 @@
+
+ dir_config("depot")
+
+-home = ENV['HOME']
+-$CFLAGS = "-I. -I../.. -I#{home}/include -I/usr/local/include"
+-$LDFLAGS = "-L../.. -L#{home}/lib -L/usr/local/lib"
+-$LIBS = "-L../.. -L#{home}/lib -L/usr/local/lib"
++$CFLAGS << " -I../.. " << ENV["CFLAGS"]
++$LDFLAGS << " -L../.. " << ENV["LDFLAGS"]
++$LIBS << " -L../.."
+
+ have_library("c", "main")
+ have_library("pthread", "main")
+--- a/ruby/depot/mod_depot.c
++++ b/ruby/depot/mod_depot.c
+@@ -83,7 +83,7 @@
+ *************************************************************************************************/
+
+
+-Init_mod_depot(){
++void Init_mod_depot(void){
+ dpinit();
+ cdepoterror = rb_define_class("DepotError", rb_eStandardError);
+ cdepoterror_ENOERR = rb_define_class("DepotError_ENOERR", cdepoterror);
+--- a/ruby/villa/extconf.rb
++++ b/ruby/villa/extconf.rb
+@@ -2,10 +2,9 @@
+
+ dir_config("villa")
+
+-home = ENV['HOME']
+-$CFLAGS = "-I. -I../.. -I#{home}/include -I/usr/local/include"
+-$LDFLAGS = "-L../.. -L#{home}/lib -L/usr/local/lib"
+-$LIBS = "-L../.. -L#{home}/lib -L/usr/local/lib"
++$CFLAGS << " -I../.. " << ENV["CFLAGS"]
++$LDFLAGS << " -L../.. " << ENV["LDFLAGS"]
++$LIBS << " -L../.."
+
+ have_library("c", "main")
+ have_library("pthread", "main")
+--- a/ruby/villa/mod_villa.c
++++ b/ruby/villa/mod_villa.c
+@@ -97,7 +97,7 @@
+ *************************************************************************************************/
+
+
+-Init_mod_villa(){
++void Init_mod_villa(void){
+ vlinit();
+ cvillaerror = rb_define_class("VillaError", rb_eStandardError);
+ cvillaerror_ENOERR = rb_define_class("VillaError_ENOERR", cvillaerror);
diff --git a/dev-db/qdbm/qdbm-1.8.78-r4.ebuild b/dev-db/qdbm/qdbm-1.8.78-r5.ebuild
index f1ea111f2075..d2b808795c42 100644
--- a/dev-db/qdbm/qdbm-1.8.78-r4.ebuild
+++ b/dev-db/qdbm/qdbm-1.8.78-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -30,6 +30,7 @@ RUBY_S="${P}/ruby"
PATCHES=(
"${FILESDIR}"/${PN}-configure.patch
"${FILESDIR}"/${PN}-perl.patch
+ "${FILESDIR}"/${PN}-ruby.patch
"${FILESDIR}"/${PN}-ruby19.patch
"${FILESDIR}"/${PN}-runpath.patch
"${FILESDIR}"/${PN}-darwin.patch