summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-09-08 19:49:07 +0200
committerDavid Seifert <soap@gentoo.org>2023-09-08 19:49:07 +0200
commit9f1e09a896fc5ff49c0b3700be57d45afb16a861 (patch)
tree61c57e685f7c0da359eb293d494f0cd405ee5040 /dev-db/sqlcipher
parentapp-admin/mcelog: add 195 (diff)
downloadgentoo-9f1e09a896fc5ff49c0b3700be57d45afb16a861.tar.gz
gentoo-9f1e09a896fc5ff49c0b3700be57d45afb16a861.tar.bz2
gentoo-9f1e09a896fc5ff49c0b3700be57d45afb16a861.zip
dev-db/sqlcipher: add 4.5.5
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-db/sqlcipher')
-rw-r--r--dev-db/sqlcipher/Manifest1
-rw-r--r--dev-db/sqlcipher/sqlcipher-4.5.5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-db/sqlcipher/Manifest b/dev-db/sqlcipher/Manifest
index 17520fbdaba4..a9cadb5ca496 100644
--- a/dev-db/sqlcipher/Manifest
+++ b/dev-db/sqlcipher/Manifest
@@ -1 +1,2 @@
DIST sqlcipher-4.5.1.tar.gz 18132121 BLAKE2B 233ffbd9636eae78533553325f08fa3ceb1e01ce0d809be44ca8ed64d46478d6a70dd40f81c38a1f0524986932ebe8614e52fda9dfc1c2f20134692cac7d4b16 SHA512 157ab90e1b80ae9ae85c68c6b77008fe8ab5b526cbb2604297a5ba54279286b4cac1fecd0db552e0113a75ff61a198f649611b8bde4dec5156c443e7b7fbe0c3
+DIST sqlcipher-4.5.5.tar.gz 18816611 BLAKE2B 46c6c64140848e02f7572afc3268db648f9968c41bd7d7e945d4918904ac572d57e0fdc049cf3dac40cc0fd0b034fb96693438ff04fffb4fcd603db2263b7ae9 SHA512 034774f8d320a53f08a9735c035bf83f81ef9223780473c39ec07658b80af89dc665599caa3b2662055039fa678c7a29cbf777d046922948e86123e677b823bc
diff --git a/dev-db/sqlcipher/sqlcipher-4.5.5.ebuild b/dev-db/sqlcipher/sqlcipher-4.5.5.ebuild
new file mode 100644
index 000000000000..ab295c81df0f
--- /dev/null
+++ b/dev-db/sqlcipher/sqlcipher-4.5.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic multilib-minimal
+
+DESCRIPTION="Full Database Encryption for SQLite"
+HOMEPAGE="https://www.zetetic.net/sqlcipher/"
+SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug libedit readline tcl test"
+# libedit and readline support are mutually exclusive
+# Testsuite requires compilation with TCL, bug #582584
+REQUIRED_USE="
+ ?? ( libedit readline )
+ test? ( tcl )"
+# Testsuite fails, bug #692310
+RESTRICT="test"
+
+# Tcl is always needed by buildsystem
+RDEPEND="
+ dev-libs/openssl:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ libedit? ( dev-libs/libedit[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:=[${MULTILIB_USEDEP}] )
+ tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-lang/tcl:*"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Column metadata added due to bug #670346
+ append-cflags -DSQLITE_HAS_CODEC -DSQLITE_ENABLE_COLUMN_METADATA
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-fts3 \
+ --enable-fts4 \
+ --enable-fts5 \
+ --enable-geopoly \
+ --enable-memsys5 \
+ --enable-rtree \
+ --enable-session \
+ --enable-tempstore \
+ $(use_enable debug) \
+ $(use_enable libedit editline) \
+ $(use_enable readline) \
+ $(use_enable tcl)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -type f -delete || die
+}