summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/xbsql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/xbsql')
-rw-r--r--dev-db/xbsql/Manifest1
-rw-r--r--dev-db/xbsql/files/xbsql-0.11-autotools.patch18
-rw-r--r--dev-db/xbsql/files/xbsql-0.11-bfr-overflow.patch79
-rw-r--r--dev-db/xbsql/files/xbsql-0.11-ncurses64.patch19
-rw-r--r--dev-db/xbsql/files/xbsql-0.11-xbase64.patch66
-rw-r--r--dev-db/xbsql/metadata.xml7
-rw-r--r--dev-db/xbsql/xbsql-0.11-r2.ebuild41
7 files changed, 231 insertions, 0 deletions
diff --git a/dev-db/xbsql/Manifest b/dev-db/xbsql/Manifest
new file mode 100644
index 000000000000..ca5e10a0fc9d
--- /dev/null
+++ b/dev-db/xbsql/Manifest
@@ -0,0 +1 @@
+DIST xbsql-0.11.tgz 307392 SHA256 c91836a4c3f138b6e211d4427dce840cd6b30853f0dffaa3bc36d05f8751606a SHA512 caf8a6d8191f7de860008e5ac2628e388097b05999887ec52b91684f6577dd3152dfa164b71a37d84ef70f43ab868dd02b30bc76c88208d4daa85d8e111ea3a4 WHIRLPOOL 0aecbb9725a2bccac9941eebb160d4dc15f8373e22641ed7a6b75c27955cf61b1ec62f59c3c496a3faa3f1ff7887a2658c08149da6cf1cc59214489ed3510919
diff --git a/dev-db/xbsql/files/xbsql-0.11-autotools.patch b/dev-db/xbsql/files/xbsql-0.11-autotools.patch
new file mode 100644
index 000000000000..b1e72562b397
--- /dev/null
+++ b/dev-db/xbsql/files/xbsql-0.11-autotools.patch
@@ -0,0 +1,18 @@
+ xbsql/Makefile.am | 7 +------
+ 1 files changed, 1 insertions(+), 6 deletions(-)
+
+diff --git a/xbsql/Makefile.am b/xbsql/Makefile.am
+index c281358..5a09198 100644
+--- a/xbsql/Makefile.am
++++ b/xbsql/Makefile.am
+@@ -1,9 +1,4 @@
+-DEBUG = -g
+-CC = g++
+-CFLAGS = -UNO_READLINE -I/usr/local/include $(DEBUG)
+-CXXFLAGS = -UNO_READLINE -I/usr/local/include $(DEBUG)
+-LDFLAGS = $(DEBUG)
+-INCLUDE = -I/usr/local/include
++CC = $(CXX)
+
+ lib_LTLIBRARIES = libxbsql.la
+ bin_PROGRAMS = xql
diff --git a/dev-db/xbsql/files/xbsql-0.11-bfr-overflow.patch b/dev-db/xbsql/files/xbsql-0.11-bfr-overflow.patch
new file mode 100644
index 000000000000..1615fb4d4389
--- /dev/null
+++ b/dev-db/xbsql/files/xbsql-0.11-bfr-overflow.patch
@@ -0,0 +1,79 @@
+ xbsql/xb_fieldset.cpp | 6 +++---
+ xbsql/xbsql.cpp | 20 ++++++++++----------
+ 2 files changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/xbsql/xb_fieldset.cpp b/xbsql/xb_fieldset.cpp
+index ea9e726..f922ed3 100644
+--- a/xbsql/xb_fieldset.cpp
++++ b/xbsql/xb_fieldset.cpp
+@@ -58,10 +58,10 @@ XBSQL::Index
+ if ((fldno < 0) || (fldno >= fieldSet.getNumFields()))
+ return XBSQL::IndexNone ;
+
+- char buff[255] ;
+- strncpy (buff, tabname, sizeof(buff)) ;
++ char buff[256] ;
++ strncpy (buff, tabname, sizeof(buff) - 1) ;
+ strncat (buff, "_", sizeof(buff)) ;
+- strncat (buff, getFieldName(fldno), sizeof(buff)) ;
++ strncat (buff, getFieldName(fldno), sizeof(buff) - strlen(tabname) - 1) ;
+
+ const char *path = xbase->getPath (buff, "ndx") ;
+ int fd = open (path, O_RDONLY) ;
+diff --git a/xbsql/xbsql.cpp b/xbsql/xbsql.cpp
+index 9d07f88..96304c4 100644
+--- a/xbsql/xbsql.cpp
++++ b/xbsql/xbsql.cpp
+@@ -376,9 +376,9 @@ bool XBaseSQL::createTable
+ char name [256] ;
+ xbNdx ndxFile (&dbfFile) ;
+
+- strncpy (name, table, sizeof(name)) ;
++ strncpy (name, table, sizeof(name) - 1) ;
+ strncat (name, "_", sizeof(name)) ;
+- strncat (name, schema[idx].FieldName, sizeof(name)) ;
++ strncat (name, schema[idx].FieldName, sizeof(name) - strlen(table) - 1) ;
+
+ path = getPath (name, "ndx") ;
+ idxflag = index[idx] == XBSQL::IndexUnique ?
+@@ -467,9 +467,9 @@ XBSQLTable *XBaseSQL::openTable
+ {
+ char name[256] ;
+
+- strncpy (name, table, sizeof(name)) ;
++ strncpy (name, table, sizeof(name) - 1) ;
+ strncat (name, "_", sizeof(name)) ;
+- strncat (name, fSet.getFieldName (idx), sizeof(name)) ;
++ strncat (name, fSet.getFieldName (idx), sizeof(name) - strlen(table) - 1) ;
+
+ path = getPath (name, "ndx") ;
+ #ifndef _WIN32
+@@ -873,12 +873,12 @@ bool XBaseSQL::renameTable
+ char _newName[256] ;
+ const char *fname = fSet.getFieldName (idx) ;
+
+- strncpy (_oldName, oldName, sizeof(_oldName)) ;
++ strncpy (_oldName, oldName, sizeof(_oldName) - 1) ;
+ strncat (_oldName, "_", sizeof(_oldName)) ;
+- strncat (_oldName, fname, sizeof(_oldName)) ;
+- strncpy (_newName, newName, sizeof(_newName)) ;
++ strncat (_oldName, fname, sizeof(_oldName) - strlen(oldName) - 1) ;
++ strncpy (_newName, newName, sizeof(_newName) - 1) ;
+ strncat (_newName, "_", sizeof(_newName)) ;
+- strncat (_newName, fname, sizeof(_newName)) ;
++ strncat (_newName, fname, sizeof(_newName) - strlen(newName) - 1) ;
+
+ oldAnon = getPath (_oldName, "ndx") ;
+ newAnon = getPath (_newName, "ndx") ;
+@@ -956,9 +956,9 @@ bool XBaseSQL::dropTable
+ char _idxName[256] ;
+ const char *fname = fSet.getFieldName (idx) ;
+
+- strncpy (_idxName, table, sizeof(_idxName)) ;
++ strncpy (_idxName, table, sizeof(_idxName) - 1) ;
+ strncat (_idxName, "_", sizeof(_idxName)) ;
+- strncat (_idxName, fname, sizeof(_idxName)) ;
++ strncat (_idxName, fname, sizeof(_idxName) - strlen(table) - 1) ;
+
+ tabAnon = getPath (_idxName, "ndx") ;
+
diff --git a/dev-db/xbsql/files/xbsql-0.11-ncurses64.patch b/dev-db/xbsql/files/xbsql-0.11-ncurses64.patch
new file mode 100644
index 000000000000..4c04d2736b0b
--- /dev/null
+++ b/dev-db/xbsql/files/xbsql-0.11-ncurses64.patch
@@ -0,0 +1,19 @@
+--- xbsql-0.11/configure.BAD 2005-08-18 10:34:49.000000000 -0500
++++ xbsql-0.11/configure 2005-08-18 10:36:22.000000000 -0500
+@@ -6977,10 +6977,15 @@
+ if test -f /usr/lib/libncurses.so
+ then
+ curses=ncurses
+-
++ elif test -f /usr/lib64/libncurses.so
++ then
++ curses=ncurses
+ elif test -f /usr/lib/libcurses.so
+ then
+ curses=curses
++ elif test -f /usr/lib64/libcurses.so
++ then
++ curses=curses
+ else
+ { { echo "$as_me:6985: error: No (n)curses installation" >&5
+ echo "$as_me: error: No (n)curses installation" >&2;}
diff --git a/dev-db/xbsql/files/xbsql-0.11-xbase64.patch b/dev-db/xbsql/files/xbsql-0.11-xbase64.patch
new file mode 100644
index 000000000000..6d51cbaf06fc
--- /dev/null
+++ b/dev-db/xbsql/files/xbsql-0.11-xbase64.patch
@@ -0,0 +1,66 @@
+diff -up xbsql-0.11/xbsql/Makefile.am.BAD xbsql-0.11/xbsql/Makefile.am
+--- xbsql-0.11/xbsql/Makefile.am.BAD 2009-08-19 23:32:27.481185284 -0400
++++ xbsql-0.11/xbsql/Makefile.am 2009-08-19 23:32:47.157206308 -0400
+@@ -17,10 +17,10 @@ libxbsql_la_SOURCES = xb_value.cpp xb_el
+ xb_assignlist.cpp xb_create.cpp \
+ xbsql.tab.c xb_datetime.cpp
+
+-libxbsql_la_LDFLAGS = -lxbase $(DEBUG)
++libxbsql_la_LIBADD = -lxbase64
+
+ xql_SOURCES = xql.cpp
+-xql_LDADD = -lxbase -lreadline -l$(CURSES) ./libxbsql.la
++xql_LDADD = -lxbase64 -lreadline -l$(CURSES) ./libxbsql.la
+
+ #
+ #
+diff -up xbsql-0.11/xbsql/Makefile.in.BAD xbsql-0.11/xbsql/Makefile.in
+--- xbsql-0.11/xbsql/Makefile.in.BAD 2009-08-19 23:32:54.384058775 -0400
++++ xbsql-0.11/xbsql/Makefile.in 2009-08-19 23:33:03.928059382 -0400
+@@ -108,10 +108,10 @@ libxbsql_la_SOURCES = xb_value.cpp xb_el
+ xbsql.tab.c xb_datetime.cpp
+
+
+-libxbsql_la_LDFLAGS = -lxbase $(DEBUG)
++libxbsql_la_LIBADD = -lxbase64
+
+ xql_SOURCES = xql.cpp
+-xql_LDADD = -lxbase -lreadline -l$(CURSES) ./libxbsql.la
++xql_LDADD = -lxbase64 -lreadline -l$(CURSES) ./libxbsql.la
+
+
+ #install-data-hook:
+diff -up xbsql-0.11/xbsql/xbsql.cpp.BAD xbsql-0.11/xbsql/xbsql.cpp
+--- xbsql-0.11/xbsql/xbsql.cpp.BAD 2009-08-19 23:34:23.880063863 -0400
++++ xbsql-0.11/xbsql/xbsql.cpp 2009-08-19 23:34:47.393184432 -0400
+@@ -207,7 +207,7 @@ void XBaseSQL::setError
+ break ;
+
+ default :
+- e = xbStrError (rc) ;
++ e = GetErrorMessage (rc) ;
+ break ;
+ }
+
+@@ -230,7 +230,7 @@ void XBaseSQL::setError
+ char t[1024] ;
+ va_list aptr ;
+
+- strcpy (t, xbStrError (rc)) ;
++ strcpy (t, GetErrorMessage (rc)) ;
+ strcat (t, ": ") ;
+ int l = strlen(t) ;
+
+diff -up xbsql-0.11/xbsql/xbsql.h.BAD xbsql-0.11/xbsql/xbsql.h
+--- xbsql-0.11/xbsql/xbsql.h.BAD 2009-08-19 23:35:45.087088919 -0400
++++ xbsql-0.11/xbsql/xbsql.h 2009-08-19 23:34:06.949184421 -0400
+@@ -43,8 +43,7 @@ XBSQL_API int strncasecmp (const char *s
+
+ #endif
+
+-#include <xbase/xbase.h>
+-#include <xbase/xbexcept.h>
++#include <xbase64/xbase64.h>
+
+ class XBaseSQL ;
+ class XBSQLTable ;
diff --git a/dev-db/xbsql/metadata.xml b/dev-db/xbsql/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-db/xbsql/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-db/xbsql/xbsql-0.11-r2.ebuild b/dev-db/xbsql/xbsql-0.11-r2.ebuild
new file mode 100644
index 000000000000..5e32efb849d5
--- /dev/null
+++ b/dev-db/xbsql/xbsql-0.11-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="An SQL Wrapper for the XBase library"
+HOMEPAGE="http://www.rekallrevealed.org/"
+SRC_URI="http://www.rekallrevealed.org/packages/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ >=dev-db/xbase-3.1.2
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ sys-devel/libtool"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ncurses64.patch
+ "${FILESDIR}"/${P}-xbase64.patch
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-bfr-overflow.patch
+)
+
+DOCS=( AUTHORS Announce ChangeLog INSTALL README TODO )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml doc/*
+}