summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-15 21:09:06 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-15 22:48:42 +0200
commitccb5796860e7dc5ca35875a8c8d7c6992472dce8 (patch)
treecae4d8e438a3ac2d2adf9e5f25992d6bdd5fbdff /dev-dotnet/csharp-gentoodotnetinfo
parentdev-dotnet/dotnet-sdk: new package; add 7.0.105 (diff)
downloadgentoo-ccb5796860e7dc5ca35875a8c8d7c6992472dce8.tar.gz
gentoo-ccb5796860e7dc5ca35875a8c8d7c6992472dce8.tar.bz2
gentoo-ccb5796860e7dc5ca35875a8c8d7c6992472dce8.zip
dev-dotnet/csharp-gentoodotnetinfo: new package; add 0.1.0
Bug: https://bugs.gentoo.org/900597 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet/csharp-gentoodotnetinfo')
-rw-r--r--dev-dotnet/csharp-gentoodotnetinfo/Manifest1
-rw-r--r--dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-0.1.0.ebuild44
-rw-r--r--dev-dotnet/csharp-gentoodotnetinfo/metadata.xml13
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-dotnet/csharp-gentoodotnetinfo/Manifest b/dev-dotnet/csharp-gentoodotnetinfo/Manifest
new file mode 100644
index 000000000000..98e4edb90b42
--- /dev/null
+++ b/dev-dotnet/csharp-gentoodotnetinfo/Manifest
@@ -0,0 +1 @@
+DIST csharp-gentoodotnetinfo-0.1.0.tar.bz2 8207 BLAKE2B d6c9bbd83b15487c669bb933c51a266788e7217a59fccb6e6fb87b66cd77ea67325859fb030d45a9ae00a542c23158a88d90ab915956d2086a4c2a3954d6a75f SHA512 78cbb0768eb8434c5ccf7c3ddbee8fc3c742e3875a05d99a72fbaa798fdd92a0bd231be873be01385b1933f51c14af9a2827e6da9495fc943898984684ab077c
diff --git a/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-0.1.0.ebuild b/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-0.1.0.ebuild
new file mode 100644
index 000000000000..dfe457e4f24f
--- /dev/null
+++ b/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-0.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT=7.0
+unset NUGET_PACKAGES
+
+inherit dotnet-pkg
+
+DESCRIPTION=".NET information tool for Gentoo"
+HOMEPAGE="https://gitlab.gentoo.org/dotnet/csharp-gentoodotnetinfo/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gentoo.org/dotnet/${PN}.git"
+else
+ SRC_URI="https://gitlab.gentoo.org/dotnet/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOTNET_PKG_PROJECTS=(
+ "${S}/Source/gentoodotnetinfo/GentooDotnetInfo/GentooDotnetInfo.csproj"
+)
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n ${EGIT_REPO_URI} ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ dotnet-pkg-base_install
+ dotnet-pkg-base_dolauncher_portable \
+ "/usr/share/${P}/GentooDotnetInfo.dll" gentoo-dotnet-info
+
+ einstalldocs
+}
diff --git a/dev-dotnet/csharp-gentoodotnetinfo/metadata.xml b/dev-dotnet/csharp-gentoodotnetinfo/metadata.xml
new file mode 100644
index 000000000000..8f2f8b5c9dde
--- /dev/null
+++ b/dev-dotnet/csharp-gentoodotnetinfo/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/xgqt/csharp-gentoodotnetinfo/-/issues/</bugs-to>
+ <remote-id type="gitlab">xgqt/csharp-gentoodotnetinfo</remote-id>
+ </upstream>
+</pkgmetadata>