summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-04 23:31:44 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-04 23:32:59 +0100
commite9cc60172270284d2c8b6fe91204522597feb54c (patch)
tree93345c2a275610641d785fa4ca6d875709eca536 /dev-dotnet
parentdev-dotnet/dotnet-sdk: add missing deps (diff)
downloadgentoo-e9cc60172270284d2c8b6fe91204522597feb54c.tar.gz
gentoo-e9cc60172270284d2c8b6fe91204522597feb54c.tar.bz2
gentoo-e9cc60172270284d2c8b6fe91204522597feb54c.zip
dev-dotnet/dotnet-sdk: add musl tarball; tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk/Manifest1
-rw-r--r--dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.100-r1.ebuild (renamed from dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.100.ebuild)24
2 files changed, 18 insertions, 7 deletions
diff --git a/dev-dotnet/dotnet-sdk/Manifest b/dev-dotnet/dotnet-sdk/Manifest
index feeff9f592e3..eef395c49c90 100644
--- a/dev-dotnet/dotnet-sdk/Manifest
+++ b/dev-dotnet/dotnet-sdk/Manifest
@@ -1,3 +1,4 @@
DIST dotnet-sdk-8.0.107-prepared-gentoo-amd64.tar.xz 1792165680 BLAKE2B 08d380090ef6475cae9a102383d0d925089733cb69f0cc97fa8fedb39ed17fcd50d5e17e5a10009640b30476220588bfd254de0c49362bfca8c015d677d58d87 SHA512 2362487033b6401e578918feabecb7d981fd87b4ab6bf09d61e5d62482c44ea6d6dd9f7fa5957abba7c537a8931d4487dd8c01ad86122af9b716bc817bed1564
DIST dotnet-sdk-8.0.107-prepared-gentoo-musl-amd64.tar.xz 1785364676 BLAKE2B 50782e24f48484e0e4bfb03f08e3a67060eb5eb15e03f09036147b041828c1ddd039cf1eae03e9c48e0197c78f68532ff4e74b7cbfbbeaf59e70262190868aa5 SHA512 b196c7fea4f75bd39093148cf4d5034773fd1aa03024ca0fddc6a117c009555b8b125d7452df071181947957ba042f964e63e8ec6d18cebb62a766add7de50db
DIST dotnet-sdk-9.0.100-prepared-gentoo-amd64.tar.xz 1911541760 BLAKE2B 0b215fad40ff48774b7c89ee83a74ec81e03b6efb19ffd6a8f934aecf38752ae74596bdb6612ded71ba40f1026b70d181a70ecd1db2af9e3dc8e0ce31c7502a6 SHA512 6b7429eef112fd18ba8bd3f3c38d0aa7d8b5337de3c0623e967d8e76f1d6efc8c645fbb89593fa95bec8b70f2e289f1f650a96912687bc3339c08a582d4ea31c
+DIST dotnet-sdk-9.0.100-prepared-gentoo-musl-amd64.tar.xz 1916495488 BLAKE2B 2d4d489fdb31ad51df03fd8b1755d2062e448ed069e92507f0115122b8490338bd717082019808f8a6be64415681ac794e4e3d1cf3ad5016d783d46016b07fa5 SHA512 bfd04e3d9cef832e7f7fd95e62730f8b5382d797020512a2cdcb239db3e24d54bb087e5cbcd40a73932486b8b48daf3941974f83e55ff3f99ca4969e31f23584
diff --git a/dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.100.ebuild b/dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.100-r1.ebuild
index dd6753552499..627f5e5a482e 100644
--- a/dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.100.ebuild
+++ b/dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.100-r1.ebuild
@@ -32,17 +32,20 @@ DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
HOMEPAGE="https://dotnet.microsoft.com/
https://github.com/dotnet/dotnet/"
SRC_URI="
-amd64? (
- elibc_glibc? (
- https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}-prepared-gentoo-amd64.tar.xz
+ amd64? (
+ elibc_glibc? (
+ https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}-prepared-gentoo-amd64.tar.xz
+ )
+ elibc_musl? (
+ https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}-prepared-gentoo-musl-amd64.tar.xz
+ )
)
-)
"
S="${WORKDIR}/${PN}-${RUNTIME_SLOT}"
LICENSE="MIT"
SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
-# KEYWORDS="~amd64" # KEYWORD-less for testing and since musl is not prepared yet.
+# KEYWORDS="~amd64" # KEYWORD-less for testing.
# STRIP="llvm-strip" corrupts some executables when using the patchelf hack.
# Be safe and restrict it for source-built too, bug https://bugs.gentoo.org/923430
@@ -171,6 +174,9 @@ src_prepare() {
unset DOTNET_ROOT
unset NUGET_PACKAGES
+ unset CLR_ICU_VERSION_OVERRIDE
+ unset USER_CLR_ICU_VERSION_OVERRIDE
+
export DOTNET_CLI_TELEMETRY_OPTOUT="1"
export DOTNET_NUGET_SIGNATURE_VERIFICATION="false"
export DOTNET_SKIP_FIRST_TIME_EXPERIENCE="1"
@@ -208,12 +214,13 @@ src_compile() {
# How it should be built.
--source-build
--clean-while-building
- --with-system-libs "+brotli+libunwind+rapidjson+zlib+"
+ --with-system-libs "+brotli+icu+libunwind+rapidjson+zlib+"
--configuration "Release"
# Auxiliary options.
--
-maxCpuCount:"$(makeopts_jobs)"
+ -p:MaxCpuCount="$(makeopts_jobs)"
-p:ContinueOnPrebuiltBaselineError="true"
# Verbosity settings.
@@ -231,11 +238,14 @@ src_install() {
dodir "${dest}"
ebegin "Extracting the .NET SDK archive"
- tar xzf artifacts/*/Release/${PN}-${SDK_SLOT}.*.tar.gz -C "${ED}/${dest}"
+ tar xzf ./artifacts/*/Release/${PN}-${SDK_SLOT}.*.tar.gz -C "${ED}/${dest}"
eend ${?} || die "extraction failed"
fperms 0755 "${dest}"
dosym -r "${dest}/dotnet" "/usr/bin/dotnet-${SDK_SLOT}"
+
+ # Fix permissions again for what is already marked as executable.
+ find "${ED}" -type f -executable -exec chmod +x {} + || die
}
pkg_postinst() {