summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-30 19:36:36 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-03 18:36:47 -0400
commit8d11899d26e069449b3f753623a3e93cdf21b063 (patch)
tree96ce49d5b6f980307c70e93327c38b83390677be /dev-games
parentdev-games/clanlib: add patch to successfully eautoreconf (diff)
downloadgentoo-8d11899d26e069449b3f753623a3e93cdf21b063.tar.gz
gentoo-8d11899d26e069449b3f753623a3e93cdf21b063.tar.bz2
gentoo-8d11899d26e069449b3f753623a3e93cdf21b063.zip
dev-games/clanlib: mark as strict-aliasing unsafe
Fixed in newer slots. Closes: https://bugs.gentoo.org/855308 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/clanlib/clanlib-0.8.1-r2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-games/clanlib/clanlib-0.8.1-r2.ebuild b/dev-games/clanlib/clanlib-0.8.1-r2.ebuild
index e14357adc276..6cb8b3b5e63e 100644
--- a/dev-games/clanlib/clanlib-0.8.1-r2.ebuild
+++ b/dev-games/clanlib/clanlib-0.8.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Multi-platform game development library"
HOMEPAGE="https://github.com/sphair/ClanLib"
@@ -67,6 +67,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/855308
+ # Fixed in newer versions
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# clanSound only controls mikmod/vorbis so there's
# no need to pass --{en,dis}able-clanSound ...
# clanDisplay only controls X, SDL, OpenGL plugins