summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-06 22:13:38 +0000
committerSam James <sam@gentoo.org>2023-02-06 22:13:38 +0000
commita27030c936e32a14b0652aaac02788b9e41a607a (patch)
treeb97dd43f128cb4a49ba25ec48de11da4d16622dd /dev-games
parentsys-fs/ext3grep: EAPI 8, fix build w/ gcc 12 (diff)
downloadgentoo-a27030c936e32a14b0652aaac02788b9e41a607a.tar.gz
gentoo-a27030c936e32a14b0652aaac02788b9e41a607a.tar.bz2
gentoo-a27030c936e32a14b0652aaac02788b9e41a607a.zip
dev-games/clanlib: fix build w/ gcc 12
Closes: https://bugs.gentoo.org/877301 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/clanlib/clanlib-0.8.1-r2.ebuild3
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc12.patch12
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-games/clanlib/clanlib-0.8.1-r2.ebuild b/dev-games/clanlib/clanlib-0.8.1-r2.ebuild
index 71d3a0c5b785..4235f050aabd 100644
--- a/dev-games/clanlib/clanlib-0.8.1-r2.ebuild
+++ b/dev-games/clanlib/clanlib-0.8.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -47,6 +47,7 @@ PATCHES=(
"${FILESDIR}/${P}-libpng15.patch"
"${FILESDIR}/${P}-docbuilder.patch"
"${FILESDIR}/${P}-glibc2.34.patch"
+ "${FILESDIR}/${P}-gcc12.patch"
)
DOCS=(
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc12.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc12.patch
new file mode 100644
index 000000000000..68ed616b3ca7
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc12.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/877301
+--- a/Sources/API/Core/System/cl_assert.h
++++ b/Sources/API/Core/System/cl_assert.h
+@@ -33,6 +33,8 @@
+ #ifndef header_cl_assert
+ #define header_cl_assert
+
++#include <cstddef>
++
+ #ifdef CL_API_DLL
+ #ifdef CL_CORE_EXPORT
+ #define CL_API_CORE __declspec(dllexport)