summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:51 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:41 +0100
commitfb647252cdeed0c36e66fb82b78468a0529de820 (patch)
treee3ff10074cc10ff2d22e3cf1e9be2f4a669e4cdb /dev-haskell/hscolour/hscolour-1.25.ebuild
parentdev-haskell/hourglass: add 0.2.12-r1 (diff)
downloadgentoo-fb647252cdeed0c36e66fb82b78468a0529de820.tar.gz
gentoo-fb647252cdeed0c36e66fb82b78468a0529de820.tar.bz2
gentoo-fb647252cdeed0c36e66fb82b78468a0529de820.zip
dev-haskell/hscolour: add 1.25
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hscolour/hscolour-1.25.ebuild')
-rw-r--r--dev-haskell/hscolour/hscolour-1.25.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/hscolour/hscolour-1.25.ebuild b/dev-haskell/hscolour/hscolour-1.25.ebuild
new file mode 100644
index 000000000000..7ab96d0275bd
--- /dev/null
+++ b/dev-haskell/hscolour/hscolour-1.25.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle"
+# avoid Cabal dependency as it's a dependency of most packages
+# including cabal depends.
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Colourise Haskell code"
+HOMEPAGE="https://code.haskell.org/~malcolm/hscolour/"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+"
+
+src_configure() {
+ # llvm-general-pure passes rtsopts
+ haskell-cabal_src_configure --ghc-options=-rtsopts
+}
+
+src_install() {
+ cabal_src_install
+ if use doc; then
+ docinto html
+ dodoc hscolour.css
+ fi
+}