summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:09 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:46 +0100
commitb0ccfc9294eab1a0d6597cd801d73733628931ac (patch)
tree31762c23128406a50d7ea5335828cac34932f318 /dev-haskell/http-date
parentdev-haskell/http-client: add 0.7.14 (diff)
downloadgentoo-b0ccfc9294eab1a0d6597cd801d73733628931ac.tar.gz
gentoo-b0ccfc9294eab1a0d6597cd801d73733628931ac.tar.bz2
gentoo-b0ccfc9294eab1a0d6597cd801d73733628931ac.zip
dev-haskell/http-date: add 0.0.11
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/http-date')
-rw-r--r--dev-haskell/http-date/Manifest1
-rw-r--r--dev-haskell/http-date/http-date-0.0.11.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/http-date/Manifest b/dev-haskell/http-date/Manifest
index 98f0133adaa0..0ff226550df7 100644
--- a/dev-haskell/http-date/Manifest
+++ b/dev-haskell/http-date/Manifest
@@ -1 +1,2 @@
+DIST http-date-0.0.11.tar.gz 5351 BLAKE2B e9f9ff3323895ea90fd98625af7fb5213d52303e2b39a661617d7635db294ec256470d6b4dc6d6c38fc2dc7f349eb3a9d4018358e7fef43b966539229ef779fe SHA512 dec4f4fc5f765887fb884a0309648dd3336e2591c05ac89150c7ebe935d1167f3c5996a12c5371f3fab3525b95ca8e46873b6bafc1b937b1b5367c256358a62d
DIST http-date-0.0.8.tar.gz 5322 BLAKE2B a88ee8ff31e5356aefa095d5c700e77554657a1102ab12091debbe173dc8b8886b3468795117b81ac745c08511b5b856ee49f6754db265226bd375926a68413c SHA512 7ad48dc20c62fea21aad0d15251cca333b56a59ca13c45be61fd9fcd938e28f5cb82701b7a394c256e1487679d0bbfcf994de90d7c8b57888e3bac8809e97114
diff --git a/dev-haskell/http-date/http-date-0.0.11.ebuild b/dev-haskell/http-date/http-date-0.0.11.ebuild
new file mode 100644
index 000000000000..36ad83942cf4
--- /dev/null
+++ b/dev-haskell/http-date/http-date-0.0.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP Date parser/formatter"
+HOMEPAGE="https://hackage.haskell.org/package/http-date"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RESTRICT=test # Ambiguous module name ‘Data.Time’: it was found in multiple packages: pulseaudio-0.0.2.1 time-1.8.0.2
+
+RDEPEND="dev-haskell/attoparsec:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/doctest-0.8
+ dev-haskell/hspec
+ dev-haskell/old-locale )
+"