summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:05 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:57 +0100
commit4cbe486bd59926b4742b06bfc07bee1ad8361794 (patch)
treee0545b5c210eec3f3697ce4d59e192a1fc3d0eef /dev-haskell/patience
parentdev-haskell/parsers: add 0.12.11 (diff)
downloadgentoo-4cbe486bd59926b4742b06bfc07bee1ad8361794.tar.gz
gentoo-4cbe486bd59926b4742b06bfc07bee1ad8361794.tar.bz2
gentoo-4cbe486bd59926b4742b06bfc07bee1ad8361794.zip
dev-haskell/patience: add 0.3
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/patience')
-rw-r--r--dev-haskell/patience/Manifest1
-rw-r--r--dev-haskell/patience/metadata.xml17
-rw-r--r--dev-haskell/patience/patience-0.3.ebuild22
3 files changed, 27 insertions, 13 deletions
diff --git a/dev-haskell/patience/Manifest b/dev-haskell/patience/Manifest
index bc128bc0b24b..e591252ebdf2 100644
--- a/dev-haskell/patience/Manifest
+++ b/dev-haskell/patience/Manifest
@@ -1 +1,2 @@
DIST patience-0.1.1.tar.gz 4610 BLAKE2B 6ce8e959dec8493990f66c9cb7b5dc8aaef6cb4edc3207f19156ba527fd993112a29a9d39241a39c2d9c4af600cebdfd31f02833779ce6cbf74e14ce6305273a SHA512 dac94580d9b82023841b5406509f8cd0e58148756e4259708c21b78b480fb4fb67b21a82c81e702275f49d90bcd1d2b46d20bb96267131d4ff57334f110e14f7
+DIST patience-0.3.tar.gz 6247 BLAKE2B d461e0739a0f03f31bee30f5940e7f3803984643b0a90b65f968ce00b5487efed7b44176d9c603f1fe566966169fd18e188c0c7efb3812ffed6db3cb5569b4e5 SHA512 12bc0005d6ca47ac9954aee8950d00f5c6af133958015fe791d2e100295660bebe967e37ce859abb67ae38bedefa1bd1d81a7770842448485d2f7466652e7ea5
diff --git a/dev-haskell/patience/metadata.xml b/dev-haskell/patience/metadata.xml
index c447e25538a3..ee2f452d0522 100644
--- a/dev-haskell/patience/metadata.xml
+++ b/dev-haskell/patience/metadata.xml
@@ -5,17 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This library implements the \"patience diff\" algorithm, as well as the patience
- algorithm for the longest increasing subsequence problem.
-
- Patience diff computes the difference between two lists, for example the
- lines of two versions of a source file. It provides a good balance of
- performance, nice output for humans, and implementation simplicity. For more
- information, see &lt;http://alfedenzo.livejournal.com/170301.html&gt; and
- &lt;http://bramcohen.livejournal.com/73318.html&gt;.
-
- New in version 0.1.1: relaxed @containers@ dependency, so it should build on
- GHC 6.10.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">patience</remote-id>
+ <remote-id type="github">chessai/patience</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/patience/patience-0.3.ebuild b/dev-haskell/patience/patience-0.3.ebuild
new file mode 100644
index 000000000000..0ea1c786e96d
--- /dev/null
+++ b/dev-haskell/patience/patience-0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Patience diff and longest increasing subsequence"
+HOMEPAGE="https://github.com/chessai/patience"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+"