summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-14 15:00:26 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-14 15:02:23 +0000
commiteda38ded2302359b091f741b33f5074b7b944230 (patch)
treee9fee3c93f44539c2912a4371c419f39c119809c /dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild
parentdev-haskell/pgp-wordlist: bump up to 0.1.0.3 (diff)
downloadgentoo-eda38ded2302359b091f741b33f5074b7b944230.tar.gz
gentoo-eda38ded2302359b091f741b33f5074b7b944230.tar.bz2
gentoo-eda38ded2302359b091f741b33f5074b7b944230.zip
dev-haskell/pcre-light: bump up to 0.4.1.0
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild')
-rw-r--r--dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild b/dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild
new file mode 100644
index 000000000000..0f291f743a7c
--- /dev/null
+++ b/dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Portable regex library for Perl 5 compatible regular expressions"
+HOMEPAGE="https://github.com/Daniel-Diaz/pcre-light"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+#IUSE="use-pkg-config"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ dev-libs/libpcre
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0
+ virtual/pkgconfig
+ test? ( >=dev-haskell/hunit-1.2.5.2
+ >=dev-haskell/mtl-2.1.3.2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=use-pkg-config \
+ --flag=-old_base
+}