summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 17:26:33 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:35 +0000
commitcbdd3332747199bc304c478b70a27acc0e3b86cc (patch)
treeb8713849a3719813f305025ec105f60f77a872c5 /dev-haskell/psqueues/psqueues-0.2.7.3.ebuild
parentdev-haskell/profunctors: add 5.6.2 (diff)
downloadgentoo-cbdd3332747199bc304c478b70a27acc0e3b86cc.tar.gz
gentoo-cbdd3332747199bc304c478b70a27acc0e3b86cc.tar.bz2
gentoo-cbdd3332747199bc304c478b70a27acc0e3b86cc.zip
dev-haskell/psqueues: add 0.2.7.3
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/psqueues/psqueues-0.2.7.3.ebuild')
-rw-r--r--dev-haskell/psqueues/psqueues-0.2.7.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/psqueues/psqueues-0.2.7.3.ebuild b/dev-haskell/psqueues/psqueues-0.2.7.3.ebuild
new file mode 100644
index 000000000000..219371c6efa3
--- /dev/null
+++ b/dev-haskell/psqueues/psqueues-0.2.7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure priority search queues"
+HOMEPAGE="https://hackage.haskell.org/package/psqueues"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
+ >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.15
+ dev-haskell/tagged
+ >=dev-haskell/tasty-1.2 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+"