summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-21 16:30:50 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-21 16:30:50 +0200
commite95da8d7a557734a51c0300b692fb08f22749140 (patch)
tree5ec4d638874f9851de53d6919a062e888d63a891 /dev-haskell
parentdev-lang/epic: Remove last-rited pkg (diff)
downloadgentoo-e95da8d7a557734a51c0300b692fb08f22749140.tar.gz
gentoo-e95da8d7a557734a51c0300b692fb08f22749140.tar.bz2
gentoo-e95da8d7a557734a51c0300b692fb08f22749140.zip
dev-haskell/certificate: Remove last-rited pkg
Closes: https://bugs.gentoo.org/735782 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/certificate/Manifest1
-rw-r--r--dev-haskell/certificate/certificate-1.3.9.ebuild43
-rw-r--r--dev-haskell/certificate/files/certificate-1.3.6/Tests/Unit.hs46
-rw-r--r--dev-haskell/certificate/files/certificate-1.3.9-ghc-7.10.patch16
-rw-r--r--dev-haskell/certificate/metadata.xml20
5 files changed, 0 insertions, 126 deletions
diff --git a/dev-haskell/certificate/Manifest b/dev-haskell/certificate/Manifest
deleted file mode 100644
index d34efbedd8e5..000000000000
--- a/dev-haskell/certificate/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST certificate-1.3.9.tar.gz 15018 BLAKE2B a89c5cf680a752dbc69f7510eae10bfa1e340090b512f1341db0742d44c13c5171cdeb3b8f0352b53ebe5fb018cb957501b01ff9d297b1a67ddeaf8cce52f265 SHA512 85ad7d1f3def68152824d0be4ccc3fb991903867fac68927eac34db366ce6f8201468a3e73c336fef6feae1ce550f614fc3ab89447b4ec7a67ac279902a815f9
diff --git a/dev-haskell/certificate/certificate-1.3.9.ebuild b/dev-haskell/certificate/certificate-1.3.9.ebuild
deleted file mode 100644
index 50aa562eef6f..000000000000
--- a/dev-haskell/certificate/certificate-1.3.9.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.4.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit eutils haskell-cabal
-
-DESCRIPTION="Certificates and Key Reader/Writer"
-HOMEPAGE="https://github.com/vincenthz/hs-certificate"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="executable test"
-RESTRICT="test" # due missing tests
-
-RDEPEND=">=dev-haskell/asn1-data-0.7.1:=[profile?] <dev-haskell/asn1-data-0.8.0:=[profile?]
- >=dev-haskell/crypto-pubkey-types-0.4:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
- dev-haskell/cryptohash:=[profile?]
- dev-haskell/mtl:=[profile?]
- >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
- >=dev-lang/ghc-6.12.1:=
- executable? ( dev-haskell/cmdargs:=[profile?]
- dev-haskell/crypto-pubkey:=[profile?]
- >=dev-haskell/text-0.11:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8.0.2
-"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.3.9-ghc-7.10.patch
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag executable executable) \
- $(cabal_flag test test)
-}
diff --git a/dev-haskell/certificate/files/certificate-1.3.6/Tests/Unit.hs b/dev-haskell/certificate/files/certificate-1.3.6/Tests/Unit.hs
deleted file mode 100644
index d97947f2b233..000000000000
--- a/dev-haskell/certificate/files/certificate-1.3.6/Tests/Unit.hs
+++ /dev/null
@@ -1,46 +0,0 @@
-module Tests.Unit
- ( runTests
- ) where
-
-import System.Directory
-import Test.HUnit
-import Control.Monad
-import Control.Applicative ((<$>))
-import Control.Exception
-import qualified Data.ByteString as B
-import qualified Data.ByteString.Lazy as L
-import Data.Certificate.X509
-import Data.List (isPrefixOf)
-
--- FIXME : make unit tests portable to run on osX and windows
-import System.Certificate.X509
-import Data.CertificateStore
-
-checkCert (X509 c mraw rawCert sigalg sigbits) = do
- let errs =
- (checkSigAlg $ certSignatureAlg c) ++
- (checkPubKey $ certPubKey c) ++
- (checkExtensions $ certExtensions c) ++
- (checkBodyRaw rawCert mraw)
- when (errs /= []) $ do
- putStrLn ("error decoding")
- mapM_ (putStrLn . (" " ++)) errs
- where
- checkExtensions ext = []
-
- checkSigAlg (SignatureALG_Unknown oid) = ["unknown signature algorithm " ++ show oid]
- checkSigAlg _ = []
-
- checkPubKey (PubKeyUnknown oid _) = ["unknown public key alg " ++ show (certPubKey c)]
- checkPubKey _ = []
-
- checkBodyRaw (Just x) (Just y) = if findsubstring y x then [] else ["cannot find body cert in original raw file"]
- checkBodyRaw _ _ = []
-
- findsubstring a b
- | L.null b = False
- | a `L.isPrefixOf` b = True
- | otherwise = findsubstring a (L.drop 1 b)
-
-runTests :: IO ()
-runTests = getSystemCertificateStore >>= mapM_ checkCert . listCertificates
diff --git a/dev-haskell/certificate/files/certificate-1.3.9-ghc-7.10.patch b/dev-haskell/certificate/files/certificate-1.3.9-ghc-7.10.patch
deleted file mode 100644
index 07a53256ded8..000000000000
--- a/dev-haskell/certificate/files/certificate-1.3.9-ghc-7.10.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/Data/Certificate/X509/Cert.hs b/Data/Certificate/X509/Cert.hs
-index 4abfadf..15e7bf8 100644
---- a/Data/Certificate/X509/Cert.hs
-+++ b/Data/Certificate/X509/Cert.hs
-@@ -1,2 +1,3 @@
-+{-# LANGUAGE FlexibleContexts #-}
- module Data.Certificate.X509.Cert
- (
-diff --git a/Data/Certificate/X509/Ext.hs b/Data/Certificate/X509/Ext.hs
-index 7595f14..8963a55 100644
---- a/Data/Certificate/X509/Ext.hs
-+++ b/Data/Certificate/X509/Ext.hs
-@@ -1,2 +1,3 @@
-+{-# LANGUAGE FlexibleContexts #-}
- -- |
- -- Module : Data.Certificate.X509.Ext
diff --git a/dev-haskell/certificate/metadata.xml b/dev-haskell/certificate/metadata.xml
deleted file mode 100644
index 3ba11e2cb4c8..000000000000
--- a/dev-haskell/certificate/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Certificates and Key reader/writer
-
- At the moment only X509 certificate and unencrypted private key are supported,
- but will include PGP certificate and pkcs8 private keys
- </longdescription>
- <use>
- <flag name="executable">Build the executable</flag>
- </use>
- <upstream>
- <remote-id type="github">vincenthz/hs-certificate</remote-id>
- </upstream>
-</pkgmetadata>