summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/c3p0
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/c3p0')
-rw-r--r--dev-java/c3p0/Manifest2
-rw-r--r--dev-java/c3p0/c3p0-0.9.1.2.ebuild55
-rw-r--r--dev-java/c3p0/metadata.xml8
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-java/c3p0/Manifest b/dev-java/c3p0/Manifest
new file mode 100644
index 000000000000..938fec84276b
--- /dev/null
+++ b/dev-java/c3p0/Manifest
@@ -0,0 +1,2 @@
+DIST c3p0-0.9.1.2-codegen.tar.bz2 15434 SHA256 c8c920d7cc240e07276525d861f88128f6403e1a123e2526796caa440b9c9025 SHA512 4b20c5307f98dfaf82676d21ec9ade0251c043322b544acea912dbc6a866773180c548aa32764fb73894daa9115ae9eec702846a2112f620e90d1e462c879075 WHIRLPOOL 6df9184ef6c1385217e74dd0a5dd21dffce37be80e7f3bc418a3b83d9062e793f20ef436d641e8f03b7b5a2bcf3ce71d19f1b09dae1660c2f103942a6aa2f1c4
+DIST c3p0-0.9.1.2.src.tgz 380118 SHA256 b837a5668a7fb0cb2338dbe26867ecc91c6e9ea030440107becb999a9a8724d3 SHA512 a33c413b5471d56d72224e3ad74996828854a2a0227bc674d5956612db517348de1f36695d16ab4cbb38827bddbe03952a5518205296fc35ecbd11b536b5aa32 WHIRLPOOL 864fd5eb470024c1f6072a886ba62732d0c1e06ae3f0cc3235b071112f0d4a20b820d4e3b68194e8af0be07567b38f219d2dc8e597f3e5d6b01afa21fb5882b9
diff --git a/dev-java/c3p0/c3p0-0.9.1.2.ebuild b/dev-java/c3p0/c3p0-0.9.1.2.ebuild
new file mode 100644
index 000000000000..373723055f2e
--- /dev/null
+++ b/dev-java/c3p0/c3p0-0.9.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="doc source"
+JAVA_PKG_WANT_BOOTCLASSPATH="1.5"
+
+inherit java-pkg-2 java-ant-2
+
+SRC_P="${P}.src"
+
+JAVA_PKG_WANT_SOURCE="1.4"
+JAVA_PKG_WANT_TARGET="1.4"
+
+DESCRIPTION="Library for augmenting traditional (DriverManager-based) JDBC drivers with JNDI-bindable DataSources"
+HOMEPAGE="http://c3p0.sourceforge.net/"
+# how to package the generated sources:
+# 1) comment out the sed build.xml calls below and compile with forced sun-jdk-1.5
+# 2) go to the ${WORKDIR}
+# 3) tar -cjf c3p0-0.9.1.2-codegen.tar.bz2 c3p0-0.9.1.2.src/build/codegen/
+SRC_URI="mirror://sourceforge/${PN}/${SRC_P}.tgz
+ mirror://gentoo/c3p0-0.9.1.2-codegen.tar.bz2"
+# Does not like Java 1.6's JDBC API
+COMMON_DEPEND="dev-java/log4j"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/${SRC_P}"
+
+src_prepare() {
+ echo "j2ee.jar.base.dir=${JAVA_HOME}" > build.properties
+ echo "log4j.jar.file=$(java-pkg_getjar log4j log4j.jar)" >> build.properties
+
+ java-ant_rewrite-bootclasspath 1.5
+ # don't generate sources, use the pregenerated from gentoo mirrors
+ # since generator uses reflection, it's not as simple as javac bootclasspath rewrite
+ sed -i 's/depends="codegen"//' build.xml
+ sed -i 's/depends="codegen,/depends="init,/' build.xml
+}
+
+EANT_DOC_TARGET="javadocs"
+
+src_install() {
+ java-pkg_newjar build/${P}.jar
+ dodoc README-SRC
+ use doc && java-pkg_dojavadoc build/apidocs
+ use source && java-pkg_dosrc src/classes/com
+}
diff --git a/dev-java/c3p0/metadata.xml b/dev-java/c3p0/metadata.xml
new file mode 100644
index 000000000000..b8f3288b7250
--- /dev/null
+++ b/dev-java/c3p0/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">c3p0</remote-id>
+ </upstream>
+</pkgmetadata>