summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jansi-native
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jansi-native')
-rw-r--r--dev-java/jansi-native/Manifest1
-rw-r--r--dev-java/jansi-native/jansi-native-1.5.ebuild41
-rw-r--r--dev-java/jansi-native/metadata.xml8
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/jansi-native/Manifest b/dev-java/jansi-native/Manifest
new file mode 100644
index 000000000000..67b1e78d5635
--- /dev/null
+++ b/dev-java/jansi-native/Manifest
@@ -0,0 +1 @@
+DIST jansi-native-1.5.tar.gz 205008 SHA256 2416e325a0092eb878f235d3771f23aedbdff2c6b85feb49a068ebfc3661b2f5 SHA512 29d178f013701b7e7844f899530f51486037e3a1403018ba4a41475ceb8d58afec768d177f64cbedd41adfb681ba08e578c2e18d956770bc039dfece8602a212 WHIRLPOOL b25c9a218b6a754bb2820722753f2adc0b67b8e04c041e5c4a6ba3e73fe9adaa21b70cf0d8bc7d2a952ceca9e0b8a407b7db1f725888e9b0d86bb11d4051336c
diff --git a/dev-java/jansi-native/jansi-native-1.5.ebuild b/dev-java/jansi-native/jansi-native-1.5.ebuild
new file mode 100644
index 000000000000..680d5edf6bbc
--- /dev/null
+++ b/dev-java/jansi-native/jansi-native-1.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit vcs-snapshot java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Native JNI component for dev-java/jansi"
+HOMEPAGE="http://jansi.fusesource.org/"
+SRC_URI="https://github.com/fusesource/${PN}/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+CDEPEND="dev-java/hawtjni-runtime:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_GENTOO_CLASSPATH="hawtjni-runtime"
+
+java_prepare() {
+ # Easier to use java-pkg-simple.
+ rm -v pom.xml || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ dodoc {changelog,readme}.md
+}
diff --git a/dev-java/jansi-native/metadata.xml b/dev-java/jansi-native/metadata.xml
new file mode 100644
index 000000000000..5321c600db61
--- /dev/null
+++ b/dev-java/jansi-native/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">fusesource/jansi-native</remote-id>
+ </upstream>
+</pkgmetadata>