summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/portletapi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/portletapi')
-rw-r--r--dev-java/portletapi/Manifest2
-rw-r--r--dev-java/portletapi/files/portletapi-1.0-build.xml120
-rw-r--r--dev-java/portletapi/metadata.xml5
-rw-r--r--dev-java/portletapi/portletapi-1.0.ebuild32
-rw-r--r--dev-java/portletapi/portletapi-2.0.ebuild38
5 files changed, 197 insertions, 0 deletions
diff --git a/dev-java/portletapi/Manifest b/dev-java/portletapi/Manifest
new file mode 100644
index 000000000000..0f45cff4d294
--- /dev/null
+++ b/dev-java/portletapi/Manifest
@@ -0,0 +1,2 @@
+DIST jetspeed-2.0-src.tar.gz 31317896 SHA256 c32a336810d934e4a627210e13e751bcd9b4257aaea78410ee1fba0c4a71cac0 SHA512 26dc10670663f9cd1faf25a9a7ad03942acc69e7b3acebf0608a84f055d9dde5e38e6ee6bce917b3efe53fd2242d04286829fd5f793caba4ebf598d899b599e4 WHIRLPOOL 0ae444ae4174ed3a0dea90ff1574c9ccb4b5b0f1389946f06d817c3225c4aa6f4d85c4030b4ac305bfaced7d3b08857b756a3e7d4ccdbf95d604edfd23bf3b27
+DIST portlet-api-2.0-sources.jar 124636 SHA256 bdba11e796e1370317e2587523925836edfb59cde438759210718fbe1d72694a SHA512 cf02030850d746b19b85bb3aa204fa7602af47fdda70d5be4c317dea01939abce96915d08186ac876b3081cd8023687e9c4bcef6f4f9a28e8a3456eaa56c8d8f WHIRLPOOL e5892a6dc6407cf1583d6b43c26d7e6a97531ed9cb42e30306638c8acd725e7df09bea744688fa2a3f8a74bd0b189a388cfd1be387fa354184565063f167c457
diff --git a/dev-java/portletapi/files/portletapi-1.0-build.xml b/dev-java/portletapi/files/portletapi-1.0-build.xml
new file mode 100644
index 000000000000..9d0b88fe1826
--- /dev/null
+++ b/dev-java/portletapi/files/portletapi-1.0-build.xml
@@ -0,0 +1,120 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!--build.xml generated by maven from project.xml version 1.0
+ on date September 19 2006, time 1721-->
+
+<project default="jar" name="portlet-api" basedir=".">
+ <property name="defaulttargetdir" value="target">
+ </property>
+ <property name="libdir" value="target/lib">
+ </property>
+ <property name="classesdir" value="target/classes">
+ </property>
+ <property name="testclassesdir" value="target/test-classes">
+ </property>
+ <property name="distdir" value="dist">
+ </property>
+ <property name="javadocdir" value="dist/docs/api">
+ </property>
+ <property name="final.name" value="portletapi">
+ </property>
+ <path id="build.classpath">
+ <fileset dir="${libdir}">
+ <include name="**/*.jar">
+ </include>
+ </fileset>
+ </path>
+ <target name="init" description="o Initializes some properties">
+ <mkdir dir="${libdir}">
+ </mkdir>
+ <condition property="noget">
+ <equals arg2="only" arg1="${build.sysclasspath}">
+ </equals>
+ </condition>
+ <!--Test if JUNIT is present in ANT classpath-->
+
+ <available property="Junit.present" classname="junit.framework.Test">
+ </available>
+ </target>
+ <target name="compile" description="o Compile the code" depends="get-deps">
+ <mkdir dir="${classesdir}">
+ </mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="src/java">
+ </pathelement>
+ </src>
+ <classpath refid="build.classpath">
+ </classpath>
+ </javac>
+ <copy todir="${classesdir}">
+ <fileset dir="src/java">
+ <exclude name="**/*.java">
+ </exclude>
+ </fileset>
+ </copy>
+ </target>
+ <target name="jar" description="o Create the jar" depends="compile,test">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
+ </jar>
+ </target>
+ <target name="clean" description="o Clean up the generated directories">
+ <delete dir="${defaulttargetdir}">
+ </delete>
+ <delete dir="${distdir}">
+ </delete>
+ </target>
+ <target name="dist" description="o Create a distribution" depends="jar, javadoc">
+ <mkdir dir="dist">
+ </mkdir>
+ <copy todir="dist">
+ <fileset dir="${defaulttargetdir}" includes="*.jar">
+ </fileset>
+ <fileset dir="${basedir}" includes="LICENSE*, README*">
+ </fileset>
+ </copy>
+ </target>
+ <target name="test" description="o Run the test cases" if="test.failure" depends="internal-test">
+ <fail message="There were test failures.">
+ </fail>
+ </target>
+ <target name="internal-test" if="Junit.present" depends="junit-present,compile-tests">
+ </target>
+ <target name="junit-present" unless="Junit.present" depends="init">
+ <echo>================================= WARNING ================================</echo>
+ <echo>Junit isn't present in your ${ANT_HOME}/lib directory. Tests not executed.</echo>
+ <echo>==========================================================================</echo>
+ </target>
+ <target name="compile-tests" if="Junit.present" depends="junit-present,compile">
+ </target>
+ <target name="javadoc" description="o Generate javadoc" depends="get-deps">
+ <mkdir dir="${javadocdir}">
+ </mkdir>
+ <tstamp>
+ <format pattern="1999-yyyy" property="year">
+ </format>
+ </tstamp>
+ <property name="copyright" value="Copyright &amp;copy; Apache Software Foundation. All Rights Reserved.">
+ </property>
+ <property name="title" value="Java Portlet API 1.0 API">
+ </property>
+ <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="src/java" packagenames="javax.portlet.*">
+ <classpath>
+ <path refid="build.classpath">
+ </path>
+ </classpath>
+ </javadoc>
+ </target>
+ <target name="get-deps" unless="noget" depends="init">
+ <!--Proxy settings works only with a JDK 1.2 and higher.-->
+
+ <setproxy>
+ </setproxy>
+ </target>
+ <target name="install-maven">
+ <get dest="${user.home}/maven-install-latest.jar" usetimestamp="true" src="${repo}/maven/maven-install-latest.jar">
+ </get>
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+</project>
diff --git a/dev-java/portletapi/metadata.xml b/dev-java/portletapi/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/portletapi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/portletapi/portletapi-1.0.ebuild b/dev-java/portletapi/portletapi-1.0.ebuild
new file mode 100644
index 000000000000..56d6184b7fb5
--- /dev/null
+++ b/dev-java/portletapi/portletapi-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+JETSPEED_P="jetspeed-2.0-src"
+DESCRIPTION="Jetspeed 2 Portlet API implementation of JSR 168"
+HOMEPAGE="http://portals.apache.org/jetspeed-2/"
+SRC_URI="mirror://apache/portals/jetspeed-2/sources/${JETSPEED_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${JETSPEED_P}/portlet-api"
+
+src_unpack() {
+ unpack ${A}
+ cp "${FILESDIR}/${P}-build.xml" "${S}/build.xml" || die
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/javax
+}
diff --git a/dev-java/portletapi/portletapi-2.0.ebuild b/dev-java/portletapi/portletapi-2.0.ebuild
new file mode 100644
index 000000000000..e5546ac9eef8
--- /dev/null
+++ b/dev-java/portletapi/portletapi-2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="portlet-api"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Portlet API 2.0 developed by the Java Community Process JSR-286"
+HOMEPAGE="https://jcp.org/en/jsr/detail?id=286"
+SRC_URI="http://mirrors.ibiblio.org/maven2/javax/portlet/${MY_PN}/${PV}/${MY_P}-sources.jar"
+
+LICENSE="Apache-2.0"
+SLOT="2.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+CDEPEND="dev-java/tomcat-servlet-api:3.0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${CDEPEND}"
+
+JAVA_SRC_DIR="src"
+
+JAVA_ENCODING="ISO-8859-1"
+JAVA_GENTOO_CLASSPATH="tomcat-servlet-api-3.0"
+
+java_prepare() {
+ mkdir src || die
+ mv * src
+}