summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/tijmp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/tijmp')
-rw-r--r--dev-java/tijmp/Manifest1
-rw-r--r--dev-java/tijmp/files/tijmp-0.8-respect-javacflags.patch11
-rw-r--r--dev-java/tijmp/files/tijmp-jni.h.patch34
-rw-r--r--dev-java/tijmp/metadata.xml12
-rw-r--r--dev-java/tijmp/tijmp-0.8.ebuild51
5 files changed, 109 insertions, 0 deletions
diff --git a/dev-java/tijmp/Manifest b/dev-java/tijmp/Manifest
new file mode 100644
index 000000000000..9fe8e8c62c37
--- /dev/null
+++ b/dev-java/tijmp/Manifest
@@ -0,0 +1 @@
+DIST tijmp-0.8.tar.gz 347809 SHA256 e6f0bc1e4a0fff6524154d3dac0f27f4f53761977ecc67d9ce20ced8ad6aac64 SHA512 911efd93c1548db45fcf8fd924675329aa82c6853ffe93074768646d08f80f4b076f336dba0da293d1acb084a12eb62c68803fa9408e2b64b2b82ab62db1de25 WHIRLPOOL 8982f4ad381472e7dd3d4012fc5ac4b56bfc4f7e62dd1f8830dbadb1303b2544727dfcd1c9330cde3fb11b05a0a7084e487089d46129b6563eece2b5a8730a85
diff --git a/dev-java/tijmp/files/tijmp-0.8-respect-javacflags.patch b/dev-java/tijmp/files/tijmp-0.8-respect-javacflags.patch
new file mode 100644
index 000000000000..96902aedf4ec
--- /dev/null
+++ b/dev-java/tijmp/files/tijmp-0.8-respect-javacflags.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,7 +18,7 @@
+ java_files := $(foreach dir,$(dirs),$(find_files))
+ class_files := $(patsubst $(jdir)/%.java,%.class,$(java_files))
+
+-JCFLAGS := -source 1.6 -encoding ISO-8859-1 -Xlint:unchecked -deprecation
++JCFLAGS := $(JAVACFLAGS) -encoding ISO-8859-1 -Xlint:unchecked -deprecation
+
+ # standard java compilation..
+ JAVACOMPILE := $(JAVAC) $(JCFLAGS) -sourcepath $(jdir) -d $(top_builddir)
diff --git a/dev-java/tijmp/files/tijmp-jni.h.patch b/dev-java/tijmp/files/tijmp-jni.h.patch
new file mode 100644
index 000000000000..e9f18cc4ee68
--- /dev/null
+++ b/dev-java/tijmp/files/tijmp-jni.h.patch
@@ -0,0 +1,34 @@
+# Patch by Vlastimil Babka <caster@gentoo.org>
+# Some JDK's such as ibm-jdk-bin don't have jni_md.h, so make the test more robust
+--- configure.ac.orig 2009-01-10 00:29:01.000000000 +0100
++++ configure.ac 2010-04-05 12:17:35.000000000 +0200
+@@ -24,22 +24,16 @@
+ JAVA_HOME=/usr/local/jdk
+ fi
+
+-jni_md=no
+-AC_CHECK_HEADERS($JAVA_HOME/include/$java_os/jni_md.h,
+- jni_md=found)
++dnl ok, maybe we dont always need include/$java_os but we use an -I for it anyway...
++CPPFLAGS="$CPPFLAGS -I$JAVA_HOME/include -I$JAVA_HOME/include/$java_os"
+
+-if test $jni_md = no
+-then
+-AC_CHECK_HEADERS($JAVA_HOME/include/jni_md.h,
+- jni_md=found)
+-fi
++jni_h=no
++AC_CHECK_HEADERS($JAVA_HOME/include/jni.h,
++ jni_h=found)
+
+-if test $jni_md = no
++if test $jni_h = no
+ then
+- AC_MSG_ERROR(Does JAVA_HOME point to the java SDK directory?)
+-else
+-dnl ok, maybe we dont need include/$java_os but we use an -I for it anyway...
+- CPPFLAGS="$CPPFLAGS -I$JAVA_HOME/include -I$JAVA_HOME/include/$java_os"
++ AC_MSG_ERROR(Could not find jni.h. Does JAVA_HOME point to the java SDK directory?)
+ fi
+
+ AC_CHECK_HEADER($JAVA_HOME/include/jvmti.h,
diff --git a/dev-java/tijmp/metadata.xml b/dev-java/tijmp/metadata.xml
new file mode 100644
index 000000000000..02ab5b4213aa
--- /dev/null
+++ b/dev-java/tijmp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+JMP is a profiler for java that can be used to trace objects usage and
+method timings. JMP uses the JVMPI interface to gather statistics
+and interact with the JVM. JMP uses a GTK+ interface to show the status.
+</longdescription>
+
+</pkgmetadata>
diff --git a/dev-java/tijmp/tijmp-0.8.ebuild b/dev-java/tijmp/tijmp-0.8.ebuild
new file mode 100644
index 000000000000..259fa531d8b2
--- /dev/null
+++ b/dev-java/tijmp/tijmp-0.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools java-pkg-2
+
+DESCRIPTION="Java Memory Profiler for java 1.6+"
+HOMEPAGE="http://www.khelekore.org/jmp/tijmp/"
+SRC_URI="http://www.khelekore.org/jmp/tijmp/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6"
+
+java_prepare() {
+ epatch "${FILESDIR}/${PN}-jni.h.patch"
+ epatch "${FILESDIR}/${P}-respect-javacflags.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" jardir="/usr/share/${PN}/lib/" install || die
+ java-pkg_regjar "${D}/usr/share/${PN}/lib/${PN}.jar"
+ java-pkg_regso "${D}/usr/$(get_libdir)/lib${PN}.so"
+
+ cat > "${T}/tijmp" <<-"EOF"
+ #!/bin/sh
+ java -Dtijmp.jar="$(java-config -p tijmp)" -agentlib:tijmp "${@}"
+EOF
+ dobin "${T}/tijmp"
+}
+
+pkg_postinst() {
+ einfo "For your convenience, ${PN} wrapper can be used to run java"
+ einfo "with profiling. Just use it in place of the 'java' command."
+}