summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-11-13 09:51:03 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-11-13 09:56:24 +0100
commitea08395afda51ef7ffb6291c38266e888ce24c7c (patch)
treeac1dc3c3236f18a43e778468e832a80c54978bf6 /dev-lang/gnat-gpl
parentprofiles: mask dev-lang/erlang-24 for removal (diff)
downloadgentoo-ea08395afda51ef7ffb6291c38266e888ce24c7c.tar.gz
gentoo-ea08395afda51ef7ffb6291c38266e888ce24c7c.tar.bz2
gentoo-ea08395afda51ef7ffb6291c38266e888ce24c7c.zip
dev-lang/gnat-gpl: fix unbundling for x86
Closes: https://bugs.gentoo.org/881165 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-lang/gnat-gpl')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
index 0ab2e943e258..c30a3ab46902 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
@@ -80,15 +80,18 @@ src_prepare() {
fi
if use bootstrap; then
- rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/ld \
+ local bundledchost=""
+ use amd64 && local bundledchost="x86_64"
+ use x86 && local bundledchost="i686"
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/${bundledchost}-pc-linux-gnu/4.7.4/ld \
|| die
ln -s /usr/bin/$CHOST-ld \
- "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/ld \
+ "${WORKDIR}"/${BTSTRP}/libexec/gcc/${bundledchost}-pc-linux-gnu/4.7.4/ld \
|| die
- rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/as \
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/${bundledchost}-pc-linux-gnu/4.7.4/as \
|| die
ln -s /usr/bin/$CHOST-as \
- "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/as \
+ "${WORKDIR}"/${BTSTRP}/libexec/gcc/${bundledchost}-pc-linux-gnu/4.7.4/as \
|| die
fi