summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-31 09:45:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-09 09:09:05 +0100
commita3ccac085653d03faa27622572cd35497941de56 (patch)
tree0a7450f084d7436bdd710631d847cd7ea8c3d7d0 /dev-lang/python
parentsys-process/atop: use upstream systemd units in 2.7.1-r1 (diff)
downloadgentoo-a3ccac085653d03faa27622572cd35497941de56.tar.gz
gentoo-a3ccac085653d03faa27622572cd35497941de56.tar.bz2
gentoo-a3ccac085653d03faa27622572cd35497941de56.zip
dev-lang/python: Depend on respective python-exec flags
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-3.10.0_p1-r1.ebuild (renamed from dev-lang/python/python-3.10.0_p1.ebuild)3
-rw-r--r--dev-lang/python/python-3.10.1-r2.ebuild (renamed from dev-lang/python/python-3.10.1.ebuild)3
-rw-r--r--dev-lang/python/python-3.10.1-r3.ebuild (renamed from dev-lang/python/python-3.10.1-r1.ebuild)3
-rw-r--r--dev-lang/python/python-3.8.12_p1-r1.ebuild (renamed from dev-lang/python/python-3.8.12_p1.ebuild)3
-rw-r--r--dev-lang/python/python-3.9.9-r1.ebuild (renamed from dev-lang/python/python-3.9.9.ebuild)3
5 files changed, 10 insertions, 5 deletions
diff --git a/dev-lang/python/python-3.10.0_p1.ebuild b/dev-lang/python/python-3.10.0_p1-r1.ebuild
index 78b9824d8ede..01166a5e84f7 100644
--- a/dev-lang/python/python-3.10.0_p1.ebuild
+++ b/dev-lang/python/python-3.10.0_p1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -34,6 +34,7 @@ RESTRICT="!test? ( test )"
RDEPEND="app-arch/bzip2:=
app-arch/xz-utils:=
+ dev-lang/python-exec[python_targets_python3_10(-)]
dev-libs/libffi:=
sys-apps/util-linux:=
>=sys-libs/zlib-1.1.3:=
diff --git a/dev-lang/python/python-3.10.1.ebuild b/dev-lang/python/python-3.10.1-r2.ebuild
index 35b7d94f0870..9731ebca9cc9 100644
--- a/dev-lang/python/python-3.10.1.ebuild
+++ b/dev-lang/python/python-3.10.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -34,6 +34,7 @@ RESTRICT="!test? ( test )"
RDEPEND="app-arch/bzip2:=
app-arch/xz-utils:=
+ dev-lang/python-exec[python_targets_python3_10(-)]
dev-libs/libffi:=
sys-apps/util-linux:=
>=sys-libs/zlib-1.1.3:=
diff --git a/dev-lang/python/python-3.10.1-r1.ebuild b/dev-lang/python/python-3.10.1-r3.ebuild
index 8182158f8060..9ce0f3c3901a 100644
--- a/dev-lang/python/python-3.10.1-r1.ebuild
+++ b/dev-lang/python/python-3.10.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -34,6 +34,7 @@ RESTRICT="!test? ( test )"
RDEPEND="app-arch/bzip2:=
app-arch/xz-utils:=
+ dev-lang/python-exec[python_targets_python3_10(-)]
dev-libs/libffi:=
sys-apps/util-linux:=
>=sys-libs/zlib-1.1.3:=
diff --git a/dev-lang/python/python-3.8.12_p1.ebuild b/dev-lang/python/python-3.8.12_p1-r1.ebuild
index 26fb6a4f96c0..5c31c44e4fe7 100644
--- a/dev-lang/python/python-3.8.12_p1.ebuild
+++ b/dev-lang/python/python-3.8.12_p1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -34,6 +34,7 @@ RESTRICT="!test? ( test )"
RDEPEND="app-arch/bzip2:=
app-arch/xz-utils:=
+ dev-lang/python-exec[python_targets_python3_8(-)]
dev-libs/libffi:=
sys-apps/util-linux:=
>=sys-libs/zlib-1.1.3:=
diff --git a/dev-lang/python/python-3.9.9.ebuild b/dev-lang/python/python-3.9.9-r1.ebuild
index 0802a4fb109e..13b6a0333c71 100644
--- a/dev-lang/python/python-3.9.9.ebuild
+++ b/dev-lang/python/python-3.9.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -34,6 +34,7 @@ RESTRICT="!test? ( test )"
RDEPEND="app-arch/bzip2:=
app-arch/xz-utils:=
+ dev-lang/python-exec[python_targets_python3_9(-)]
dev-libs/libffi:=
sys-apps/util-linux:=
>=sys-libs/zlib-1.1.3:=