summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-01-04 18:53:22 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-01-04 18:54:33 +0100
commit2328f28b225d9b77711a08ef839a6084f17b834d (patch)
tree29931fec7f94e0315c3f446d57b6c48703a25838 /dev-lang/smlnj
parentdev-libs/openspecfun: version bump to 0.5.5 (diff)
downloadgentoo-2328f28b225d9b77711a08ef839a6084f17b834d.tar.gz
gentoo-2328f28b225d9b77711a08ef839a6084f17b834d.tar.bz2
gentoo-2328f28b225d9b77711a08ef839a6084f17b834d.zip
dev-lang/smlnj: replace sed delimeter
Closes: https://bugs.gentoo.org/717016 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/smlnj')
-rw-r--r--dev-lang/smlnj/smlnj-110.82.ebuild14
-rw-r--r--dev-lang/smlnj/smlnj-110.99.2.ebuild12
2 files changed, 13 insertions, 13 deletions
diff --git a/dev-lang/smlnj/smlnj-110.82.ebuild b/dev-lang/smlnj/smlnj-110.82.ebuild
index 68c776772b8d..6e3b7303f61c 100644
--- a/dev-lang/smlnj/smlnj-110.82.ebuild
+++ b/dev-lang/smlnj/smlnj-110.82.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -83,11 +83,11 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-110.82-pax-p3.patch"
default
for file in mk.*; do
- sed -e "/^AS/s:as:$(tc-getAS):" \
- -e "/^CC/s:gcc:$(tc-getCC):" \
- -e "/^CPP/s:gcc:$(tc-getCC):" \
- -e "/^CFLAGS/{s:-O[0123s]:: ; s:=:= ${CFLAGS}:}" \
- -e "/^PAXMARK/s:true:"$(usex pax-kernel "paxmark.sh" "true")":" \
+ sed -e "/^AS/s|as|$(tc-getAS)|" \
+ -e "/^CC/s|gcc|$(tc-getCC)|" \
+ -e "/^CPP/s|gcc|$(tc-getCC)|" \
+ -e "/^CFLAGS/{s|-O[0123s]|| ; s|=|= ${CFLAGS}|}" \
+ -e "/^PAXMARK/s|true|"$(usex pax-kernel "paxmark.sh" "true")"|" \
-i base/runtime/objs/${file}
done
}
@@ -138,7 +138,7 @@ src_install() {
DIR=/usr/${SUBDIR}
for file in bin/{*,.*}; do
[[ -f ${file} ]] && sed -e "2iSMLNJ_HOME=${EPREFIX}/${DIR}" \
- -e "s:${WORKDIR}:${EPREFIX}/${DIR}:" -i ${file}
+ -e "s|${WORKDIR}|${EPREFIX}/${DIR}|" -i ${file}
done
dodir ${DIR}/bin
exeinto ${DIR}/bin
diff --git a/dev-lang/smlnj/smlnj-110.99.2.ebuild b/dev-lang/smlnj/smlnj-110.99.2.ebuild
index 98c8b3ecdf06..247d06dc4ca7 100644
--- a/dev-lang/smlnj/smlnj-110.99.2.ebuild
+++ b/dev-lang/smlnj/smlnj-110.99.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -84,10 +84,10 @@ src_prepare() {
default
# respect CC et al. (bug 243886)
- sed -e "/^AS/s:as:$(tc-getAS):" \
- -e "/^CC/s:gcc:$(tc-getCC):" \
- -e "/^CPP/s:gcc:$(tc-getCC):" \
- -e "/^CFLAGS/{s:-O[0123s]:: ; s:=:= ${CFLAGS}:}" \
+ sed -e "/^AS/s|as|$(tc-getAS)|" \
+ -e "/^CC/s|gcc|$(tc-getCC)|" \
+ -e "/^CPP/s|gcc|$(tc-getCC)|" \
+ -e "/^CFLAGS/{s|-O[0123s]|| ; s|=|= ${CFLAGS}|}" \
-i base/runtime/objs/mk.* || die
sed -i "s|nm |$(tc-getNM) |g" config/chk-global-names.sh || die
@@ -109,7 +109,7 @@ src_install() {
for file in bin/{*,.*} ; do
[[ -f ${file} ]] &&
sed -e "2iSMLNJ_HOME=${EPREFIX}/${DIR}" \
- -e "s:${WORKDIR}:${EPREFIX}/${DIR}:" \
+ -e "s|${WORKDIR}|${EPREFIX}/${DIR}|" \
-i ${file}
done