summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2018-11-17 10:57:20 -0500
committerIan Stakenvicius <axs@gentoo.org>2018-11-17 11:51:29 -0500
commit5457e2f4fb34e39402ce387a67788022ef53d414 (patch)
treef00a13202f76da25e8026c65a2e0d6d40e007a0e /dev-lang/spidermonkey
parentx11-libs/pango: update dev-libs/glib dep (diff)
downloadgentoo-5457e2f4fb34e39402ce387a67788022ef53d414.tar.gz
gentoo-5457e2f4fb34e39402ce387a67788022ef53d414.tar.bz2
gentoo-5457e2f4fb34e39402ce387a67788022ef53d414.zip
dev-lang/spidermonkey: fix SHELL every way possible
The changes in this commit are overkill, but with v60 built using mach there isn't any form of precedent to set with this code, and ensuring these assignments occur will squash this bug once and for all no matter how it manifests. Bug: https://bugs.gentoo.org/666732 Signed-off-by: Ian Stakenvicius <axs@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-lang/spidermonkey')
-rw-r--r--dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild b/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild
index 990f45f27fe8..cadf22413d78 100644
--- a/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-52.9.1_pre1.ebuild
@@ -34,6 +34,8 @@ DEPEND="${RDEPEND}"
pkg_setup(){
[[ ${MERGE_TYPE} == "binary" ]] || \
moz_pkgsetup
+
+ export SHELL="${EPREFIX}/bin/bash"
}
src_prepare() {
@@ -91,6 +93,7 @@ cross_make() {
CC="${BUILD_CC}" \
CXX="${BUILD_CXX}" \
RANLIB="${BUILD_RANLIB}" \
+ SHELL="${SHELL:-${EPREFIX}/bin/bash}" \
"$@"
}
src_compile() {
@@ -120,6 +123,7 @@ src_compile() {
fi
MOZ_MAKE_FLAGS="${MAKEOPTS}" \
+ SHELL="${SHELL:-${EPREFIX}/bin/bash}" \
emake \
MOZ_OPTIMIZE_FLAGS="" MOZ_DEBUG_FLAGS="" \
HOST_OPTIMIZE_FLAGS="" MODULE_OPTIMIZE_FLAGS="" \
@@ -133,6 +137,7 @@ src_test() {
src_install() {
cd "${BUILDDIR}" || die
+ SHELL="${SHELL:-${EPREFIX}/bin/bash}" \
emake DESTDIR="${D}" install
if ! use minimal; then