summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-07 16:27:12 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-07 18:38:02 +0100
commit4b4bcc9ddd00d2df3d42a47ca464df715cca5356 (patch)
treea3ecab0b2bb9d537628a6ee00f85ab88fb55fa06 /dev-lang/typescript
parentdev-lang/typescript: drop old 5.3.2 (diff)
downloadgentoo-4b4bcc9ddd00d2df3d42a47ca464df715cca5356.tar.gz
gentoo-4b4bcc9ddd00d2df3d42a47ca464df715cca5356.tar.bz2
gentoo-4b4bcc9ddd00d2df3d42a47ca464df715cca5356.zip
dev-lang/typescript: bump to 5.4.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/typescript')
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-5.4.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index fc6f16bf54f2..63dd16f04c49 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1 +1,2 @@
DIST typescript-5.3.3.tgz 5761919 BLAKE2B 629d2d97a9d57f63cd693a6d77cc385058778c4e4de6002f5e2646c64d1b8ff80386290435b2c838f647bc76f626e4dfd9613e1237d53fa5e4b98f503fbdf9ea SHA512 a5759cadac4cd2ec404beb4dd001bf045d93caa9873b4d78674ef452c27ea45bd8b914aaf0a1fc0e65a99db5ded2910f0c75d957715c01b2648a3279a0d1275b
+DIST typescript-5.4.2.tgz 5824544 BLAKE2B a22ecc8a17be22da10263746537d5ce0a0af359866773d6d4d081332a82436c734628d0d89134db63f46fae57f62f6e674f420cea2fff902c1be1a25307b03d8 SHA512 fb6fe0d0576cd444653fa26c6a44100d78d975930cfabaa96a61592442a1e24c13227de20e480ab5bcb409e35de404cd678472d5ac75e53331d16d95fa68a2cd
diff --git a/dev-lang/typescript/typescript-5.4.2.ebuild b/dev-lang/typescript/typescript-5.4.2.ebuild
new file mode 100644
index 000000000000..2be080b52222
--- /dev/null
+++ b/dev-lang/typescript/typescript-5.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}