summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-15 06:59:42 +0000
committerSam James <sam@gentoo.org>2024-12-15 07:01:52 +0000
commit053fb81af3f45277e1869d993c240f38d0346a71 (patch)
tree0eceb6cb267002415922c89f4f6a11c5f32e4c06 /dev-lang
parentx11-wm/fvwm3: stop forcing `-fsigned-char` on some arches (diff)
downloadgentoo-053fb81af3f45277e1869d993c240f38d0346a71.tar.gz
gentoo-053fb81af3f45277e1869d993c240f38d0346a71.tar.bz2
gentoo-053fb81af3f45277e1869d993c240f38d0346a71.zip
Revert "dev-lang/rust-bin: remove hard gcc dependency"
This reverts commit 0a2e3e056ba70d19df59f2a22a44e3a53abe933e. This (clearly) doesn't work if symbols from libgcc_s are relied upon, like __popcountdi2. Needing sys-devel/gcc for now for rust-bin is better than having it entirely broken. Discussions on a broader fix are in progress on the bug. Bug: https://bugs.gentoo.org/944835 Bug: https://bugs.gentoo.org/946321 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-bin/rust-bin-1.71.1-r101.ebuild15
-rw-r--r--dev-lang/rust-bin/rust-bin-1.74.1-r101.ebuild15
-rw-r--r--dev-lang/rust-bin/rust-bin-1.75.0-r101.ebuild15
-rw-r--r--dev-lang/rust-bin/rust-bin-1.77.1-r101.ebuild15
-rw-r--r--dev-lang/rust-bin/rust-bin-1.79.0-r101.ebuild15
-rw-r--r--dev-lang/rust-bin/rust-bin-1.80.1-r101.ebuild15
-rw-r--r--dev-lang/rust-bin/rust-bin-1.81.0-r101.ebuild15
-rw-r--r--dev-lang/rust-bin/rust-bin-1.82.0-r101.ebuild15
8 files changed, 16 insertions, 104 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.71.1-r101.ebuild b/dev-lang/rust-bin/rust-bin-1.71.1-r101.ebuild
index 3a37b965eca8..9e716ace2e5b 100644
--- a/dev-lang/rust-bin/rust-bin-1.71.1-r101.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.71.1-r101.ebuild
@@ -24,19 +24,18 @@ SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="${PV}"
KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix llvm-libunwind rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
RDEPEND="
>=app-eselect/eselect-rust-20190311
dev-libs/openssl
sys-apps/lsb-release
- !llvm-libunwind? ( sys-devel/gcc:* )
+ sys-devel/gcc:*
!dev-lang/rust:stable
!dev-lang/rust-bin:stable
"
BDEPEND="
prefix? ( dev-util/patchelf )
- llvm-libunwind? ( dev-util/patchelf )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -131,16 +130,6 @@ multilib_src_install() {
eend ${PIPESTATUS[0]}
fi
- if use llvm-libunwind; then
- ebegin "Replacing libgcc_s with libunwind"
- find "${ED}/opt/${P}"/{bin,lib,libexec} -type f -print0 | \
- while IFS= read -r -d '' filename; do
- # just ignore wrong filetype error, instead of checking redundantly
- patchelf --replace-needed libgcc_s.so.1 libunwind.so.1 ${filename} 2>/dev/null
- done
- eend ${PIPESTATUS[0]}
- fi
-
local symlinks=(
cargo
rustc
diff --git a/dev-lang/rust-bin/rust-bin-1.74.1-r101.ebuild b/dev-lang/rust-bin/rust-bin-1.74.1-r101.ebuild
index 27f76c86c891..23d2616783ae 100644
--- a/dev-lang/rust-bin/rust-bin-1.74.1-r101.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.74.1-r101.ebuild
@@ -34,19 +34,18 @@ SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4"
SLOT="${PV}"
KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix llvm-libunwind rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
RDEPEND="
>=app-eselect/eselect-rust-20190311
dev-libs/openssl
sys-apps/lsb-release
- !llvm-libunwind? ( sys-devel/gcc:* )
+ sys-devel/gcc:*
!dev-lang/rust:stable
!dev-lang/rust-bin:stable
"
BDEPEND="
prefix? ( dev-util/patchelf )
- llvm-libunwind? ( dev-util/patchelf )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -141,16 +140,6 @@ multilib_src_install() {
eend ${PIPESTATUS[0]}
fi
- if use llvm-libunwind; then
- ebegin "Replacing libgcc_s with libunwind"
- find "${ED}/opt/${P}"/{bin,lib,libexec} -type f -print0 | \
- while IFS= read -r -d '' filename; do
- # just ignore wrong filetype error, instead of checking redundantly
- patchelf --replace-needed libgcc_s.so.1 libunwind.so.1 ${filename} 2>/dev/null
- done
- eend ${PIPESTATUS[0]}
- fi
-
local symlinks=(
cargo
rustc
diff --git a/dev-lang/rust-bin/rust-bin-1.75.0-r101.ebuild b/dev-lang/rust-bin/rust-bin-1.75.0-r101.ebuild
index d8816da33893..9bb32c144c66 100644
--- a/dev-lang/rust-bin/rust-bin-1.75.0-r101.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.75.0-r101.ebuild
@@ -34,19 +34,18 @@ SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4"
SLOT="${PV}"
KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix llvm-libunwind rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
RDEPEND="
>=app-eselect/eselect-rust-20190311
dev-libs/openssl
sys-apps/lsb-release
- !llvm-libunwind? ( sys-devel/gcc:* )
+ sys-devel/gcc:*
!dev-lang/rust:stable
!dev-lang/rust-bin:stable
"
BDEPEND="
prefix? ( dev-util/patchelf )
- llvm-libunwind? ( dev-util/patchelf )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -141,16 +140,6 @@ multilib_src_install() {
eend ${PIPESTATUS[0]}
fi
- if use llvm-libunwind; then
- ebegin "Replacing libgcc_s with libunwind"
- find "${ED}/opt/${P}"/{bin,lib,libexec} -type f -print0 | \
- while IFS= read -r -d '' filename; do
- # just ignore wrong filetype error, instead of checking redundantly
- patchelf --replace-needed libgcc_s.so.1 libunwind.so.1 ${filename} 2>/dev/null
- done
- eend ${PIPESTATUS[0]}
- fi
-
local symlinks=(
cargo
rustc
diff --git a/dev-lang/rust-bin/rust-bin-1.77.1-r101.ebuild b/dev-lang/rust-bin/rust-bin-1.77.1-r101.ebuild
index 957aa1b35be3..5eb6567f5cdd 100644
--- a/dev-lang/rust-bin/rust-bin-1.77.1-r101.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.77.1-r101.ebuild
@@ -34,19 +34,18 @@ SRC_URI+=" mips? (
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4"
SLOT="${PV}"
KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix llvm-libunwind rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
RDEPEND="
>=app-eselect/eselect-rust-20190311
dev-libs/openssl
sys-apps/lsb-release
- !llvm-libunwind? ( sys-devel/gcc:* )
+ sys-devel/gcc:*
!dev-lang/rust:stable
!dev-lang/rust-bin:stable
"
BDEPEND="
prefix? ( dev-util/patchelf )
- llvm-libunwind? ( dev-util/patchelf )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -141,16 +140,6 @@ multilib_src_install() {
eend ${PIPESTATUS[0]}
fi
- if use llvm-libunwind; then
- ebegin "Replacing libgcc_s with libunwind"
- find "${ED}/opt/${P}"/{bin,lib,libexec} -type f -print0 | \
- while IFS= read -r -d '' filename; do
- # just ignore wrong filetype error, instead of checking redundantly
- patchelf --replace-needed libgcc_s.so.1 libunwind.so.1 ${filename} 2>/dev/null
- done
- eend ${PIPESTATUS[0]}
- fi
-
local symlinks=(
cargo
rustc
diff --git a/dev-lang/rust-bin/rust-bin-1.79.0-r101.ebuild b/dev-lang/rust-bin/rust-bin-1.79.0-r101.ebuild
index fbba0eaafe7c..55b9d0d15962 100644
--- a/dev-lang/rust-bin/rust-bin-1.79.0-r101.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.79.0-r101.ebuild
@@ -37,19 +37,18 @@ SRC_URI+=" riscv? (
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4"
SLOT="${PV}"
KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix llvm-libunwind rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
RDEPEND="
>=app-eselect/eselect-rust-20190311
dev-libs/openssl
sys-apps/lsb-release
- !llvm-libunwind? ( sys-devel/gcc:* )
+ sys-devel/gcc:*
!dev-lang/rust:stable
!dev-lang/rust-bin:stable
"
BDEPEND="
prefix? ( dev-util/patchelf )
- llvm-libunwind? ( dev-util/patchelf )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -144,16 +143,6 @@ multilib_src_install() {
eend ${PIPESTATUS[0]}
fi
- if use llvm-libunwind; then
- ebegin "Replacing libgcc_s with libunwind"
- find "${ED}/opt/${P}"/{bin,lib,libexec} -type f -print0 | \
- while IFS= read -r -d '' filename; do
- # just ignore wrong filetype error, instead of checking redundantly
- patchelf --replace-needed libgcc_s.so.1 libunwind.so.1 ${filename} 2>/dev/null
- done
- eend ${PIPESTATUS[0]}
- fi
-
local symlinks=(
cargo
rustc
diff --git a/dev-lang/rust-bin/rust-bin-1.80.1-r101.ebuild b/dev-lang/rust-bin/rust-bin-1.80.1-r101.ebuild
index cc54b88837b5..8b3aab679bda 100644
--- a/dev-lang/rust-bin/rust-bin-1.80.1-r101.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.80.1-r101.ebuild
@@ -41,19 +41,18 @@ SRC_URI+=" ppc64? ( elibc_musl? (
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4"
SLOT="${PV}"
KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix llvm-libunwind rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
RDEPEND="
>=app-eselect/eselect-rust-20190311
dev-libs/openssl
sys-apps/lsb-release
- !llvm-libunwind? ( sys-devel/gcc:* )
+ sys-devel/gcc:*
!dev-lang/rust:stable
!dev-lang/rust-bin:stable
"
BDEPEND="
prefix? ( dev-util/patchelf )
- llvm-libunwind? ( dev-util/patchelf )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -148,16 +147,6 @@ multilib_src_install() {
eend ${PIPESTATUS[0]}
fi
- if use llvm-libunwind; then
- ebegin "Replacing libgcc_s with libunwind"
- find "${ED}/opt/${P}"/{bin,lib,libexec} -type f -print0 | \
- while IFS= read -r -d '' filename; do
- # just ignore wrong filetype error, instead of checking redundantly
- patchelf --replace-needed libgcc_s.so.1 libunwind.so.1 ${filename} 2>/dev/null
- done
- eend ${PIPESTATUS[0]}
- fi
-
local symlinks=(
cargo
rustc
diff --git a/dev-lang/rust-bin/rust-bin-1.81.0-r101.ebuild b/dev-lang/rust-bin/rust-bin-1.81.0-r101.ebuild
index 92018fea9922..aabb1ed9c384 100644
--- a/dev-lang/rust-bin/rust-bin-1.81.0-r101.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.81.0-r101.ebuild
@@ -41,19 +41,18 @@ SRC_URI+=" ppc64? ( elibc_musl? (
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4"
SLOT="${PV}"
KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix llvm-libunwind rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
RDEPEND="
>=app-eselect/eselect-rust-20190311
dev-libs/openssl
sys-apps/lsb-release
- !llvm-libunwind? ( sys-devel/gcc:* )
+ sys-devel/gcc:*
!dev-lang/rust:stable
!dev-lang/rust-bin:stable
"
BDEPEND="
prefix? ( dev-util/patchelf )
- llvm-libunwind? ( dev-util/patchelf )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -148,16 +147,6 @@ multilib_src_install() {
eend ${PIPESTATUS[0]}
fi
- if use llvm-libunwind; then
- ebegin "Replacing libgcc_s with libunwind"
- find "${ED}/opt/${P}"/{bin,lib,libexec} -type f -print0 | \
- while IFS= read -r -d '' filename; do
- # just ignore wrong filetype error, instead of checking redundantly
- patchelf --replace-needed libgcc_s.so.1 libunwind.so.1 ${filename} 2>/dev/null
- done
- eend ${PIPESTATUS[0]}
- fi
-
local symlinks=(
cargo
rustc
diff --git a/dev-lang/rust-bin/rust-bin-1.82.0-r101.ebuild b/dev-lang/rust-bin/rust-bin-1.82.0-r101.ebuild
index a4cbf3b1c091..b1a1d5f9037b 100644
--- a/dev-lang/rust-bin/rust-bin-1.82.0-r101.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.82.0-r101.ebuild
@@ -41,19 +41,18 @@ SRC_URI+=" ppc64? ( elibc_musl? (
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4"
SLOT="${PV}"
KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix llvm-libunwind rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
RDEPEND="
>=app-eselect/eselect-rust-20190311
dev-libs/openssl
sys-apps/lsb-release
- !llvm-libunwind? ( sys-devel/gcc:* )
+ sys-devel/gcc:*
!dev-lang/rust:stable
!dev-lang/rust-bin:stable
"
BDEPEND="
prefix? ( dev-util/patchelf )
- llvm-libunwind? ( dev-util/patchelf )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -150,16 +149,6 @@ multilib_src_install() {
eend ${PIPESTATUS[0]}
fi
- if use llvm-libunwind; then
- ebegin "Replacing libgcc_s with libunwind"
- find "${ED}/opt/${P}"/{bin,lib,libexec} -type f -print0 | \
- while IFS= read -r -d '' filename; do
- # just ignore wrong filetype error, instead of checking redundantly
- patchelf --replace-needed libgcc_s.so.1 libunwind.so.1 ${filename} 2>/dev/null
- done
- eend ${PIPESTATUS[0]}
- fi
-
local symlinks=(
cargo
rustc