summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-06 00:45:18 +0100
committerSam James <sam@gentoo.org>2023-04-06 01:31:46 +0100
commit33f6f605fb2bb432134103d3de13d8ebe9f5b146 (patch)
tree951c8cd1ca2484fe460cf18035f3660a74cb9998 /dev-lang
parentprofiles/base: mask openjdk:11[lto] (diff)
downloadgentoo-33f6f605fb2bb432134103d3de13d8ebe9f5b146.tar.gz
gentoo-33f6f605fb2bb432134103d3de13d8ebe9f5b146.tar.bz2
gentoo-33f6f605fb2bb432134103d3de13d8ebe9f5b146.zip
dev-lang/python: skip test_tools for PGO
Skip the 'test_tools' test when running PGO for now to avoid hanging the build (and also kind of fork-bombing the system with recursive cpython build attempts). Interestingly, not seen this when running the actual regular testsuite, but I suppose far fewer people actually run that, so could just be a frequency thing. Bug: https://bugs.gentoo.org/828535 Bug: https://bugs.gentoo.org/850154 Bug: https://bugs.gentoo.org/903890 Closes: https://bugs.gentoo.org/900429 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.11.ebuild4
-rw-r--r--dev-lang/python/python-3.11.3.ebuild4
-rw-r--r--dev-lang/python/python-3.12.0_alpha7.ebuild4
-rw-r--r--dev-lang/python/python-3.9.16_p3.ebuild4
4 files changed, 16 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.10.11.ebuild b/dev-lang/python/python-3.10.11.ebuild
index fa6da52fc33b..0e9df1369b1b 100644
--- a/dev-lang/python/python-3.10.11.ebuild
+++ b/dev-lang/python/python-3.10.11.ebuild
@@ -192,6 +192,10 @@ src_configure() {
-x test_multiprocessing_fork
-x test_socket
-x test_xmlrpc
+
+ # Hangs (actually runs indefinitely executing itself w/ many cpython builds)
+ # bug #900429
+ -x test_tools
)
if has_version "app-arch/rpm" ; then
diff --git a/dev-lang/python/python-3.11.3.ebuild b/dev-lang/python/python-3.11.3.ebuild
index 930a7259e6bc..83f671a8ef6f 100644
--- a/dev-lang/python/python-3.11.3.ebuild
+++ b/dev-lang/python/python-3.11.3.ebuild
@@ -179,6 +179,10 @@ src_configure() {
-x test_multiprocessing_fork
-x test_socket
-x test_xmlrpc
+
+ # Hangs (actually runs indefinitely executing itself w/ many cpython builds)
+ # bug #900429
+ -x test_tools
)
if has_version "app-arch/rpm" ; then
diff --git a/dev-lang/python/python-3.12.0_alpha7.ebuild b/dev-lang/python/python-3.12.0_alpha7.ebuild
index abbc74ddf678..94d6f02c4f80 100644
--- a/dev-lang/python/python-3.12.0_alpha7.ebuild
+++ b/dev-lang/python/python-3.12.0_alpha7.ebuild
@@ -174,6 +174,10 @@ src_configure() {
-x test_multiprocessing_fork
-x test_socket
-x test_xmlrpc
+
+ # Hangs (actually runs indefinitely executing itself w/ many cpython builds)
+ # bug #900429
+ -x test_tools
)
if has_version "app-arch/rpm" ; then
diff --git a/dev-lang/python/python-3.9.16_p3.ebuild b/dev-lang/python/python-3.9.16_p3.ebuild
index 1796c12df3a1..618909e14b3b 100644
--- a/dev-lang/python/python-3.9.16_p3.ebuild
+++ b/dev-lang/python/python-3.9.16_p3.ebuild
@@ -188,6 +188,10 @@ src_configure() {
-x test_multiprocessing_fork
-x test_socket
-x test_xmlrpc
+
+ # Hangs (actually runs indefinitely executing itself w/ many cpython builds)
+ # bug #900429
+ -x test_tools
)
if has_version "app-arch/rpm" ; then