summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-12-23 18:42:51 +0100
committerMichał Górny <mgorny@gentoo.org>2015-12-23 19:07:40 +0100
commit9483c233c49989f12e192847b5248055f896a0a2 (patch)
tree50acb153a2ec89b57140adc90b60a73db6a0bddd /dev-lang
parentdev-db/mariadb: Version bump for 5.5.47 (diff)
downloadgentoo-9483c233c49989f12e192847b5248055f896a0a2.tar.gz
gentoo-9483c233c49989f12e192847b5248055f896a0a2.tar.bz2
gentoo-9483c233c49989f12e192847b5248055f896a0a2.zip
dev-lang/python: Install a wrapper to fix python-config paths, #569506
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.3.5-r7.ebuild (renamed from dev-lang/python/python-3.3.5-r6.ebuild)9
-rw-r--r--dev-lang/python/python-3.4.3-r7.ebuild (renamed from dev-lang/python/python-3.4.3-r6.ebuild)9
-rw-r--r--dev-lang/python/python-3.5.1-r2.ebuild (renamed from dev-lang/python/python-3.5.1-r1.ebuild)9
3 files changed, 21 insertions, 6 deletions
diff --git a/dev-lang/python/python-3.3.5-r6.ebuild b/dev-lang/python/python-3.3.5-r7.ebuild
index a85ba3c29109..877112f5541c 100644
--- a/dev-lang/python/python-3.3.5-r6.ebuild
+++ b/dev-lang/python/python-3.3.5-r7.ebuild
@@ -318,8 +318,13 @@ src_install() {
ln -s "python${pymajor}" \
"${D}${PYTHON_SCRIPTDIR}/python" || die
# python-config and pythonX-config
- ln -s "../../../bin/${abiver}-config" \
- "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" || die
+ # note: we need to create a wrapper rather than symlinking it due
+ # to some random dirname(argv[0]) magic performed by python-config
+ cat > "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" <<-EOF || die
+ #!/bin/sh
+ exec "${abiver}-config" "\${@}"
+ EOF
+ chmod +x "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" || die
ln -s "python${pymajor}-config" \
"${D}${PYTHON_SCRIPTDIR}/python-config" || die
# 2to3, pydoc, pyvenv
diff --git a/dev-lang/python/python-3.4.3-r6.ebuild b/dev-lang/python/python-3.4.3-r7.ebuild
index 98549fa3b728..f599fd900e5a 100644
--- a/dev-lang/python/python-3.4.3-r6.ebuild
+++ b/dev-lang/python/python-3.4.3-r7.ebuild
@@ -301,8 +301,13 @@ src_install() {
ln -s "python${pymajor}" \
"${D}${PYTHON_SCRIPTDIR}/python" || die
# python-config and pythonX-config
- ln -s "../../../bin/${abiver}-config" \
- "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" || die
+ # note: we need to create a wrapper rather than symlinking it due
+ # to some random dirname(argv[0]) magic performed by python-config
+ cat > "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" <<-EOF || die
+ #!/bin/sh
+ exec "${abiver}-config" "\${@}"
+ EOF
+ chmod +x "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" || die
ln -s "python${pymajor}-config" \
"${D}${PYTHON_SCRIPTDIR}/python-config" || die
# 2to3, pydoc, pyvenv
diff --git a/dev-lang/python/python-3.5.1-r1.ebuild b/dev-lang/python/python-3.5.1-r2.ebuild
index ef7c58e30a94..bf753fab3174 100644
--- a/dev-lang/python/python-3.5.1-r1.ebuild
+++ b/dev-lang/python/python-3.5.1-r2.ebuild
@@ -304,8 +304,13 @@ src_install() {
ln -s "python${pymajor}" \
"${D}${PYTHON_SCRIPTDIR}/python" || die
# python-config and pythonX-config
- ln -s "../../../bin/${abiver}-config" \
- "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" || die
+ # note: we need to create a wrapper rather than symlinking it due
+ # to some random dirname(argv[0]) magic performed by python-config
+ cat > "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" <<-EOF || die
+ #!/bin/sh
+ exec "${abiver}-config" "\${@}"
+ EOF
+ chmod +x "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" || die
ln -s "python${pymajor}-config" \
"${D}${PYTHON_SCRIPTDIR}/python-config" || die
# 2to3, pydoc, pyvenv