summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2024-06-06 18:59:53 +0500
committerSam James <sam@gentoo.org>2024-12-15 09:47:06 +0000
commitb68ca211734f85e6a98efd2e5c1cb96e27a7998d (patch)
tree4db47ad81869045ee9133617c48e7fc9259211da /dev-lang
parentdev-lang/zig: add 0.13.0-r2 (diff)
downloadgentoo-b68ca211734f85e6a98efd2e5c1cb96e27a7998d.tar.gz
gentoo-b68ca211734f85e6a98efd2e5c1cb96e27a7998d.tar.bz2
gentoo-b68ca211734f85e6a98efd2e5c1cb96e27a7998d.zip
dev-lang/zig: sync 9999 with 0.13.0-r2
* Update to use zig-utils and zig eclasses instead of local get_zig_mcpu etc. functions. * "stage3" compilation is unified by combining build.zig options, now both cmake (+llvm) and bootstrap.c (-llvm) build up to "zig2" target, after that we use zig.eclass with common options. * Before migrating to the zig.eclass, test steps in src_test have been ran sequentially in for-loop, which allowed logic inside each step to ran parallelly but not several steps at a time. Now we use upstream "test" step instead of separately calling all dependant steps, so that build system can now ran all of them paralelly. This means time spent in `src_test` is now significantly shorter. * "zig2" in both scenarios now has explicit target which is set by using zig-utils.eclass functions on a CBUILD/CHOST. This allows us to skip convertion logic in CMake and bootstrap.c, so that instead of patching them we can just update converter in zig-utils.eclass and unify target behaviour. * Disable autodocs generation for "std" module, since it can now be generated on-fly with `zig std` command. Signed-off-by: Eric Joldasov <bratishkaerik@landless-city.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/zig/zig-9999.ebuild235
1 files changed, 121 insertions, 114 deletions
diff --git a/dev-lang/zig/zig-9999.ebuild b/dev-lang/zig/zig-9999.ebuild
index 858ec3be9405..4f0358a96629 100644
--- a/dev-lang/zig/zig-9999.ebuild
+++ b/dev-lang/zig/zig-9999.ebuild
@@ -6,10 +6,13 @@ EAPI=8
LLVM_COMPAT=( 19 )
LLVM_OPTIONAL=1
-inherit check-reqs cmake edo llvm-r1 toolchain-funcs
+ZIG_SLOT="$(ver_cut 1-2)"
+ZIG_OPTIONAL=1
+
+inherit check-reqs cmake flag-o-matic edo llvm-r1 toolchain-funcs zig
DESCRIPTION="A robust, optimal, and maintainable programming language"
-HOMEPAGE="https://ziglang.org/"
+HOMEPAGE="https://ziglang.org/ https://github.com/ziglang/zig/"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/ziglang/zig.git"
inherit git-r3
@@ -39,14 +42,15 @@ fi
# lib/libc/mingw: ZPL public-domain BSD-2 ISC HPND
# lib/libc/glibc: BSD HPND ISC inner-net LGPL-2.1+
LICENSE="MIT Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT ) || ( Apache-2.0-with-LLVM-exceptions Apache-2.0 MIT BSD-2 ) public-domain BSD-2 ZPL ISC HPND BSD inner-net LGPL-2.1+"
-SLOT="$(ver_cut 1-2)"
+SLOT="${ZIG_SLOT}"
IUSE="doc +llvm"
REQUIRED_USE="
!llvm? ( !doc )
llvm? ( ${LLVM_REQUIRED_USE} )
"
-BUILD_DIR="${S}/build"
+# Used by both "cmake" and "zig" eclasses.
+BUILD_DIR="${WORKDIR}/${P}_build"
# Zig requires zstd and zlib compression support in LLVM, if using LLVM backend.
# (non-LLVM backends don't require these)
@@ -62,173 +66,176 @@ DEPEND="
')
)
"
-
-RDEPEND="
+BDEPEND+="
${DEPEND}
"
-
+RDEPEND="${DEPEND}"
IDEPEND="app-eselect/eselect-zig"
-# see https://github.com/ziglang/zig/issues/3382
-# For now, Zig Build System doesn't support enviromental CFLAGS/LDFLAGS/etc.
-QA_FLAGS_IGNORED="usr/.*/zig/${PV}/bin/zig"
+DOCS=( "README.md" "doc/build.zig.zon.md" )
-RESTRICT="!llvm? ( test )"
+# zig.eclass does not set this for us since we use ZIG_OPTIONAL=1
+QA_FLAGS_IGNORED="usr/.*/zig/${PV}/bin/zig"
# Since commit https://github.com/ziglang/zig/commit/e7d28344fa3ee81d6ad7ca5ce1f83d50d8502118
# Zig uses self-hosted compiler only
CHECKREQS_MEMORY="4G"
-ctarget_to_zigtarget() {
- # Zig's Target Format: arch-os-abi
- local CTARGET="${CTARGET:-${CHOST}}"
-
- local ZIG_ARCH
- case "${CTARGET%%-*}" in
- i?86) ZIG_ARCH=x86;;
- sparcv9) ZIG_ARCH=sparc64;;
- *) ZIG_ARCH="${CTARGET%%-*}";; # Same as in CHOST
- esac
-
- local ZIG_OS
- case "${CTARGET}" in
- *linux*) ZIG_OS=linux;;
- *apple*) ZIG_OS=macos;;
- esac
-
- local ZIG_ABI
- case "${CTARGET##*-}" in
- gnu) ZIG_ABI=gnu;;
- solaris*) ZIG_OS=solaris ZIG_ABI=none;;
- darwin*) ZIG_ABI=none;;
- *) ZIG_ABI="${CTARGET##*-}";; # Same as in CHOST
- esac
-
- echo "${ZIG_ARCH}-${ZIG_OS}-${ZIG_ABI}"
-}
+pkg_setup() {
+ # Skip detecting zig executable.
+ ZIG_EXE="not-applicable" ZIG_VER="${PV}" zig_pkg_setup
-get_zig_mcpu() {
- local ZIG_DEFAULT_MCPU=native
- tc-is-cross-compiler && ZIG_DEFAULT_MCPU=baseline
- echo "${ZIG_MCPU:-${ZIG_DEFAULT_MCPU}}"
-}
+ export ZIG_SYS_INSTALL_DEST="${EPREFIX}/usr/$(get_libdir)/zig/${PV}"
+
+ if use llvm; then
+ tc-is-cross-compiler && die "USE=llvm is not yet supported when cross-compiling"
+ llvm-r1_pkg_setup
+ fi
-get_zig_target() {
- local ZIG_DEFAULT_TARGET=native
- tc-is-cross-compiler && ZIG_DEFAULT_TARGET="$(ctarget_to_zigtarget)"
- echo "${ZIG_TARGET:-${ZIG_DEFAULT_TARGET}}"
+ check-reqs_pkg_setup
}
-pkg_setup() {
- # Useful for debugging and a little bit more deterministic.
- export ZIG_LOCAL_CACHE_DIR="${T}/zig-local-cache"
- export ZIG_GLOBAL_CACHE_DIR="${T}/zig-global-cache"
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ else
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.minisig}
+ fi
+ fi
+ zig_src_unpack
+}
- export ZIG_SYS_INSTALL_DEST="${EPREFIX}/usr/$(get_libdir)/zig/${PV}"
+src_prepare() {
+ if use llvm; then
+ cmake_src_prepare
+ else
+ # Sync with zig_src_prepare
+ default_src_prepare
+ mkdir -p "${BUILD_DIR}" || die
+ einfo "BUILD_DIR: \"${BUILD_DIR}\""
+ # "--system" mode is not used during bootstrap.
+ fi
- use llvm && llvm-r1_pkg_setup
- check-reqs_pkg_setup
+ # Remove "limit memory usage" flags, it's already verified by
+ # CHECKREQS_MEMORY and causes unneccessary errors. Upstream set them
+ # according to CI OOM failures, which are not applicable to normal Gentoo build.
+ sed -i -e '/\.max_rss = .*,/d' build.zig || die
}
src_configure() {
- if ! use llvm; then
- mkdir -p "${BUILD_DIR}/stage3" || die
- # Currently, Zig without LLVM extensions lacks most optimizations.
- export ZIG_BOOTSTRAP_STAGE3_FLAGS=(
- -Dtarget="$(get_zig_target)"
- -Dcpu="$(get_zig_mcpu)"
- -Doptimize=Debug
- -Dstd-docs=false
- -Dno-langref
+ # Has no effect on final binary and only causes failures during bootstrapping.
+ filter-lto
+
+ # Used during bootstrapping. stage1/stage2 have limited functionality
+ # and can't resolve native target, so we pass target in exact form.
+ declare -r -g ZIG_HOST_AS_TARGET="$(zig-utils_c_env_to_zig_target "${CBUILD:-${CHOST}}" "${CFLAGS}"})"
+
+ # Note that if we are building with CMake, "my_zbs_args"
+ # are used only after compiling zig2.
+ local my_zbs_args=(
+ --zig-lib-dir "${S}/lib/"
+ # Will be a subdir under ZIG_SYS_INSTALL_DEST.
+ --prefix-lib-dir lib/
+
+ # These are built separately
+ -Dno-langref
+ -Dstd-docs=false
+
+ --release=fast
+ )
+ if use llvm; then
+ my_zbs_args+=(
+ -Denable-llvm=true
+ -Dstatic-llvm=false
+ -Dconfig_h="${BUILD_DIR}/config.h"
+ )
+ else
+ my_zbs_args+=(
-Denable-llvm=false
- -Dforce-link-libc
)
- return
fi
- local mycmakeargs=(
- -DZIG_USE_CCACHE=OFF
- -DZIG_SHARED_LLVM=ON
- -DZIG_TARGET_TRIPLE="$(get_zig_target)"
- -DZIG_TARGET_MCPU="$(get_zig_mcpu)"
- -DZIG_USE_LLVM_CONFIG=ON
- -DCMAKE_PREFIX_PATH="$(get_llvm_prefix)"
- -DCMAKE_INSTALL_PREFIX="${ZIG_SYS_INSTALL_DEST}"
- )
+ zig_src_configure
+
+ if use llvm; then
+ # Build for native only, it's for zig2 (build-time executable)
+ # LLVM from BDEPEND
+ local mycmakeargs=(
+ -DZIG_SHARED_LLVM=ON
+ -DZIG_USE_LLVM_CONFIG=ON
- cmake_src_configure
+ -DZIG_TARGET_TRIPLE=native
+ -DZIG_TARGET_MCPU=native
+ -DZIG_HOST_TARGET_TRIPLE="${ZIG_HOST_AS_TARGET}"
+
+ -DCMAKE_PREFIX_PATH="$(get_llvm_prefix -b)"
+ -DCMAKE_INSTALL_PREFIX="${ZIG_SYS_INSTALL_DEST}"
+ )
+
+ cmake_src_configure
+ fi
}
src_compile() {
- # Remove "limit memory usage" flags, it's already verified by
- # CHECKREQS_MEMORY and causes unneccessary errors. Upstream set them
- # according to CI OOM failures, which are higher than during Gentoo build.
- sed -i -e '/\.max_rss = .*,/d' build.zig || die
+ if use llvm; then
+ cmake_build zig2
+ else
+ cd "${BUILD_DIR}" || die
+ ln -s "${S}/stage1/" . || die
+ ln -s "${S}/src/" . || die
+ ln -s "${S}/lib/" . || die
- if ! use llvm; then
- $(tc-getCC) -o bootstrap bootstrap.c || die "Zig's bootstrap.c compilation failed"
- edob ./bootstrap
- edo ./zig2 build install --prefix "${BUILD_DIR}/stage3/" "${ZIG_BOOTSTRAP_STAGE3_FLAGS[@]}"
- return
+ local native_cc="$(tc-getBUILD_CC)"
+ "${native_cc}" -o bootstrap "${S}/bootstrap.c" || die "Zig's bootstrap.c compilation failed"
+ ZIG_HOST_TARGET_TRIPLE="${ZIG_HOST_AS_TARGET}" CC="${native_cc}" edo ./bootstrap
fi
- cmake_src_compile
+ cd "${BUILD_DIR}" || die
+ ZIG_EXE="./zig2" zig_src_compile --prefix "${BUILD_DIR}/stage3/"
- "${BUILD_DIR}/stage3/bin/zig" env || die "Zig compilation failed"
+ ./stage3/bin/zig env || die "Zig compilation failed"
if use doc; then
- cd "${BUILD_DIR}" || die
- edo ./stage3/bin/zig build std-docs --zig-lib-dir "${BUILD_DIR}/stage3/lib/zig/" --prefix "${S}/docgen/"
- edo ./stage3/bin/zig build langref --zig-lib-dir "${BUILD_DIR}/stage3/lib/zig/" --prefix "${S}/docgen/"
+ ZIG_EXE="./stage3/bin/zig" zig_src_compile langref --prefix "${S}/docgen/"
fi
}
src_test() {
cd "${BUILD_DIR}" || die
- local ZIG_TEST_ARGS="-Dstatic-llvm=false -Denable-llvm -Dskip-non-native \
- -Doptimize=ReleaseSafe -Dtarget=$(get_zig_target) -Dcpu=$(get_zig_mcpu)"
- local ZIG_TEST_STEPS=(
- test-fmt test-cases test-behavior test-c-import test-compiler-rt test-universal-libc test-compare-output
- test-standalone test-c-abi test-link test-stack-traces test-cli test-asm-link test-translate-c
- test-run-translated-c test-std
- )
-
- local step
- for step in "${ZIG_TEST_STEPS[@]}" ; do
- edob ./stage3/bin/zig build ${step} ${ZIG_TEST_ARGS}
- done
+ ZIG_EXE="./stage3/bin/zig" zig_src_test -Dskip-non-native
}
src_install() {
- local DOCS=( "README.md" "doc/build.zig.zon.md" )
- use doc && local HTML_DOCS=( "docgen/doc/langref.html" "docgen/doc/std" )
+ use doc && local HTML_DOCS=( "docgen/doc/langref.html" )
- if ! use llvm; then
- DESTDIR="${D}" edo ./zig2 build install --prefix "${ZIG_SYS_INSTALL_DEST}" "${ZIG_BOOTSTRAP_STAGE3_FLAGS[@]}"
- einstalldocs
- else
- cmake_src_install
- fi
+ ZIG_EXE="./zig2" zig_src_install --prefix "${ZIG_SYS_INSTALL_DEST}"
- cd "${ED}/usr/$(get_libdir)/zig/${PV}/" || die
+ cd "${D}/${ZIG_SYS_INSTALL_DEST}" || die
mv lib/zig/ lib2/ || die
rm -rf lib/ || die
mv lib2/ lib/ || die
- dosym -r "/usr/$(get_libdir)/zig/${PV}/bin/zig" "/usr/bin/zig-${PV}"
+ dosym -r "${ZIG_SYS_INSTALL_DEST}/bin/zig" /usr/bin/zig-${PV}
}
pkg_postinst() {
- eselect zig update ifunset
+ eselect zig update ifunset || die
+
+ elog "Starting from 0.12.0, Zig no longer installs"
+ elog "precompiled standard library documentation."
+ elog "Instead, you can call \`zig std\` to compile it on-the-fly."
+ elog "It reflects all edits in standard library automatically."
+ elog "See \`zig std --help\` for more information."
+ elog "More details here: https://ziglang.org/download/0.12.0/release-notes.html#Redesign-How-Autodoc-Works"
if ! use llvm; then
elog "Currently, Zig built without LLVM support lacks some"
elog "important features such as most optimizations, @cImport, etc."
elog "They are listed under \"Building from Source without LLVM\""
elog "section of the README file from \"/usr/share/doc/${PF}\" ."
- elog "It's recommended to use C backend directly with this stage2 build."
fi
}
pkg_postrm() {
- eselect zig update ifunset
+ eselect zig update ifunset || die
}