summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-07-15 17:40:35 +0000
committerSam James <sam@gentoo.org>2020-07-15 17:42:10 +0000
commit4466bd5c995a0ff31a16cc8c901a28c61536a76b (patch)
tree854329ff6d7e661501662bfc86d7d1b74084d57f /dev-libs/botan
parentapp-mobilephone/{kannel,kannel-sqlbox}: drop last-rited pkgs (diff)
downloadgentoo-4466bd5c995a0ff31a16cc8c901a28c61536a76b.tar.gz
gentoo-4466bd5c995a0ff31a16cc8c901a28c61536a76b.tar.bz2
gentoo-4466bd5c995a0ff31a16cc8c901a28c61536a76b.zip
dev-libs/botan: bump to 2.15.0
Changes: * General style changes to the ebuild (inherited most of it before, now time to make it my own -- last time was a security bump). * Fix {B,R,}DEPEND to be populated correctly, in particular with respect to Python at build time, but there are other DEPEND fixes too. URL: https://botan.randombit.net/news.html#version-2-15-0-2020-07-07 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest1
-rw-r--r--dev-libs/botan/botan-2.15.0.ebuild132
2 files changed, 133 insertions, 0 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index ec1ecd8e0cb3..ae7a46615519 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,2 +1,3 @@
DIST Botan-2.14.0.tar.xz 5958948 BLAKE2B 90e73945b22f6e4e8d6163bfb45eca153eb1495448f8bf35514b780fd12bb1b81c822314e1f598c7625277f1e9cf7a6265387cca80ffd4c2664c681b9d4807fd SHA512 ee15928ecdb0127720b444b0207d46fd68fe3007125b0deb8bdd32f96e9befb684ad54009354da4f6a3c48b9698693b46223710a47fd644da8760dda53d40d34
+DIST Botan-2.15.0.tar.xz 5920688 BLAKE2B 1bbb9cadb0f754194851bddf8b14dbcd291285c5f3fbaad35920277a11c3d9e1b1e5cc484c0d37b1c7999b3084a1c90da56631df0b07e788372b95aff5197031 SHA512 0965a0a6141df44e38bd7da038b89dd2b3808ed9a4ebaafbf089abf60718e62cba78d7b64eaf272b5df8c5a489222e4cad4fb511cde38e76cdaed87f35896c18
DIST Botan-2.9.0.tgz 7216373 BLAKE2B 5ad2e15db871ccc3a32b29b7f54a02d69f251f0aca2ce656b557dbbb3814a793053a54905371b3414ad72952a64bece43e2383da91f205f68b0fe31be2f9439c SHA512 b88f3894a4a5b7b2fbff9be6eb0b774bf679a014bd2364811b7e63d4f323e22ca9ef916491afbc2cdf9db68727c1449fbeb6fd417e591560add0955517db3f65
diff --git a/dev-libs/botan/botan-2.15.0.ebuild b/dev-libs/botan/botan-2.15.0.ebuild
new file mode 100644
index 000000000000..df5fd9c8af9a
--- /dev/null
+++ b/dev-libs/botan/botan-2.15.0.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit python-r1 toolchain-funcs
+
+MY_P="Botan-${PV}"
+
+DESCRIPTION="C++ crypto library"
+HOMEPAGE="https://botan.randombit.net/"
+SRC_URI="https://botan.randombit.net/releases/${MY_P}.tar.xz"
+LICENSE="BSD-2"
+
+SLOT="2/$(ver_cut 1-2)" # soname version
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE="bindist bzip2 boost doc libressl lzma python sqlite ssl static-libs zlib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ')
+"
+
+# NOTE: Boost is needed at runtime too for the CLI tool.
+DEPEND="
+ boost? ( >=dev-libs/boost-1.48:= )
+ bzip2? ( >=app-arch/bzip2-1.0.5:= )
+ lzma? ( app-arch/xz-utils:= )
+ python? ( ${PYTHON_DEPS} )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ sqlite? ( dev-db/sqlite:3= )
+ zlib? ( >=sys-libs/zlib-1.2.3:= )
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+# NOTE: Considering patching Botan?
+# Please see upstream's guidance:
+# https://botan.randombit.net/handbook/packaging.html#minimize-distribution-patches
+
+python_check_deps() {
+ if use doc ; then
+ has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]" || return 1
+ fi
+}
+
+src_configure() {
+ local disable_modules=()
+ use boost || disable_modules+=( "boost" )
+ use bindist && disable_modules+=( "ecdsa" )
+ elog "Disabling module(s): ${disable_modules[@]}"
+
+ # Enable v9 instructions for sparc64
+ local chostarch="${CHOST%%-*}"
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]] ; then
+ chostarch="sparc32-v9"
+ fi
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ case ${CHOST} in
+ hppa*) chostarch=parisc ;;
+ esac
+
+ local pythonvers=()
+ if use python ; then
+ _append() {
+ pythonvers+=( ${EPYTHON/python/} )
+ }
+
+ python_foreach_impl _append
+ fi
+
+ # Don't install Python bindings automatically
+ # (do it manually later in the right place)
+ # https://bugs.gentoo.org/723096
+ local myargs=(
+ $(use_enable static-libs static-library)
+ $(use_with boost)
+ $(use_with bzip2)
+ $(use_with doc documentation)
+ $(use_with doc sphinx)
+ $(use_with lzma)
+ $(use_with sqlite sqlite3)
+ $(use_with ssl openssl)
+ $(use_with zlib)
+ $(usex hppa --without-stack-protector '')
+ --cpu=${chostarch}
+ --disable-modules=$( IFS=","; echo "${disable_modules[*]}" )
+ --docdir=share/doc
+ --libdir=$(get_libdir)
+ --os=${myos}
+ --distribution-info="Gentoo ${PVR}"
+ --prefix="${EPREFIX}/usr"
+ --with-endian="$(tc-endian)"
+ --with-python-version=$( IFS=","; echo "${pythonvers[*]}" )
+ --without-doxygen
+ --no-install-python-module
+ )
+
+ tc-export CC CXX AR
+
+ ./configure.py "${myargs[@]}" || die "configure.py failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+}
+
+src_install() {
+ default
+
+ # Manually install the Python bindings (bug #723096)
+ if use python ; then
+ python_foreach_impl python_domodule src/python/botan2.py
+ fi
+}