summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-30 20:27:30 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-30 20:29:19 +0100
commit4c638d1eb0ee325f8953e0c01e80ff058aa38932 (patch)
treedd8ec27079639d5c501c497c127e52ccf8b5ebb1 /dev-libs/libclc/libclc-19.1.3.ebuild
parentsys-devel/clang-runtime: Add 19.1.3 (diff)
downloadgentoo-4c638d1eb0ee325f8953e0c01e80ff058aa38932.tar.gz
gentoo-4c638d1eb0ee325f8953e0c01e80ff058aa38932.tar.bz2
gentoo-4c638d1eb0ee325f8953e0c01e80ff058aa38932.zip
dev-libs/libclc: Add 19.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libclc/libclc-19.1.3.ebuild')
-rw-r--r--dev-libs/libclc/libclc-19.1.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/libclc/libclc-19.1.3.ebuild b/dev-libs/libclc/libclc-19.1.3.ebuild
new file mode 100644
index 000000000000..369d04fb2877
--- /dev/null
+++ b/dev-libs/libclc/libclc-19.1.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_COMPAT=( {17..18} )
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake llvm.org llvm-r1 python-any-r1
+
+DESCRIPTION="OpenCL C library"
+HOMEPAGE="https://libclc.llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions || ( MIT BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="+spirv video_cards_nvidia video_cards_r600 video_cards_radeonsi"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(llvm_gen_dep '
+ sys-devel/clang:${LLVM_SLOT}
+ spirv? ( dev-util/spirv-llvm-translator:${LLVM_SLOT} )
+ ')
+"
+
+LLVM_COMPONENTS=( libclc )
+llvm.org_set_globals
+
+pkg_setup() {
+ llvm-r1_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local libclc_targets=()
+
+ use spirv && libclc_targets+=(
+ "spirv-mesa3d-"
+ "spirv64-mesa3d-"
+ )
+ use video_cards_nvidia && libclc_targets+=(
+ "nvptx--"
+ "nvptx64--"
+ "nvptx--nvidiacl"
+ "nvptx64--nvidiacl"
+ )
+ use video_cards_r600 && libclc_targets+=(
+ "r600--"
+ )
+ use video_cards_radeonsi && libclc_targets+=(
+ "amdgcn--"
+ "amdgcn-mesa-mesa3d"
+ "amdgcn--amdhsa"
+ )
+ [[ ${#libclc_targets[@]} ]] || die "libclc target missing!"
+
+ libclc_targets=${libclc_targets[*]}
+ local mycmakeargs=(
+ -DLIBCLC_TARGETS_TO_BUILD="${libclc_targets// /;}"
+ )
+ cmake_src_configure
+}