summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-04-20 08:20:52 +0800
committerYixun Lan <dlan@gentoo.org>2022-04-20 08:36:53 +0800
commit5de5b893520423567e28dee634f082134670840e (patch)
tree5ede97f4cca1bb2e12ca08bbd64d0b8d97e365cc /dev-libs/libfilezilla/files
parentapp-emacs/pkg-info: tests fail (diff)
downloadgentoo-5de5b893520423567e28dee634f082134670840e.tar.gz
gentoo-5de5b893520423567e28dee634f082134670840e.tar.bz2
gentoo-5de5b893520423567e28dee634f082134670840e.zip
dev-libs/libfilezilla: use -pthread to fix atomic issue
the -pthread flag will expand link option "-latomic" in RISC-V platfrom, so will effectively fix the problem. Closes: https://bugs.gentoo.org/837740 Upstream report: https://trac.filezilla-project.org/ticket/12699 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-libs/libfilezilla/files')
-rw-r--r--dev-libs/libfilezilla/files/libfilezilla-0.37.1-pthread.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-libs/libfilezilla/files/libfilezilla-0.37.1-pthread.patch b/dev-libs/libfilezilla/files/libfilezilla-0.37.1-pthread.patch
new file mode 100644
index 000000000000..6a40cc69c52e
--- /dev/null
+++ b/dev-libs/libfilezilla/files/libfilezilla-0.37.1-pthread.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 14bb5d0..da45769 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -120,7 +120,7 @@ AC_CHECK_DECLS([pthread_condattr_setclock], [], [], [[#include <pthread.h>]])
+ if test "$windows" = "1"; then
+ libdeps="-lws2_32"
+ else
+- libdeps=-lpthread
++ libdeps=-pthread
+ CHECK_ICONV([libdeps="$libdeps -liconv"])
+
+ CHECK_RANDOM