summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-07-29 09:22:38 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-07-29 09:22:38 +0200
commit77469ac8951b03109dc91e17da6cd6beba2858bb (patch)
tree644733e46584d337dd00da781cbc7955ad422093 /dev-libs/libfilezilla
parentdev-libs/libfilezilla: drop 0.39.2, 0.41.0, 0.41.1 (diff)
downloadgentoo-77469ac8951b03109dc91e17da6cd6beba2858bb.tar.gz
gentoo-77469ac8951b03109dc91e17da6cd6beba2858bb.tar.bz2
gentoo-77469ac8951b03109dc91e17da6cd6beba2858bb.zip
dev-libs/libfilezilla: add 0.44.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-libs/libfilezilla')
-rw-r--r--dev-libs/libfilezilla/Manifest1
-rw-r--r--dev-libs/libfilezilla/libfilezilla-0.44.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/libfilezilla/Manifest b/dev-libs/libfilezilla/Manifest
index d8d30df8a76a..f0c7e32a5713 100644
--- a/dev-libs/libfilezilla/Manifest
+++ b/dev-libs/libfilezilla/Manifest
@@ -1,2 +1,3 @@
DIST libfilezilla-0.39.1.tar.bz2 622574 BLAKE2B 2845f0309f8a9036f42930203b89d503ffe5897dbb819cc9249b3179deb24f5c562843471712702d7a302df0b3c7dead1bc108de9dd5dd4b1cb1501cd3ef9ba1 SHA512 b5c4dcaef146ea3e249a4972e66aa441187693bea148f0ead0c08568ecf1856a78c7455cbc70737d82b9c33c2af5d6abe79dd4cb2dfbb65bdcefd6765016dfb6
DIST libfilezilla-0.42.2.tar.xz 529032 BLAKE2B 08d4f48d4b4d38ba8cc52779d7e3b589d5bd7c76a2ab74f668064e49c4eb1d85f676715f363baae0660a2d04def82aed53e57e4bc7e9f97f0934802adc523c1d SHA512 a453854f3a7143a63a2fc79458096e9b8f2f6a07f480cb15a0c0873a4cc147c0373d6f1647e1dd3dece015fbdedc3ce3085d4c7d26c801c0948fd1c593fd6d8c
+DIST libfilezilla-0.44.0.tar.xz 541136 BLAKE2B 73344ef8cebdfb6334204baf37e9cb9ab4171fe7307fc186b77139e912aa7a8dd9d9970f765a1c7059d146cdae69ce81571749052cc4b981841229058225badc SHA512 44547cfce1c2b33cbddbd3c7150613d050c9d6f1130e7969b0ad26e96d4e18a0a7251ca045e1dba1442a1d9c7f19e463b5eab7985a0cc98e652caf79809d291f
diff --git a/dev-libs/libfilezilla/libfilezilla-0.44.0.ebuild b/dev-libs/libfilezilla/libfilezilla-0.44.0.ebuild
new file mode 100644
index 000000000000..f0062aa87af1
--- /dev/null
+++ b/dev-libs/libfilezilla/libfilezilla-0.44.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit flag-o-matic
+
+DESCRIPTION="C++ library offering some basic functionality for platform-independent programs"
+HOMEPAGE="https://lib.filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/40" # libfilezilla.so version
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/nettle:0=
+ >=net-libs/gnutls-3.5.7:=
+ virtual/libcrypt:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.37.1-pthread.patch
+ "${FILESDIR}"/${PN}-0.41.0-gcc13.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_configure() {
+ if use ppc || use arm || use hppa; then
+ # bug 727652
+ append-libs -latomic
+ fi
+
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}