summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-02-08 12:02:48 -0800
committerMatt Turner <mattst88@gentoo.org>2020-02-08 12:11:44 -0800
commit37cdf73a4158483cffb10c9ea74cd787166902e6 (patch)
tree3e7cb0dd52b27db272ce0feaeb721e1497669559 /dev-libs/libgweather
parentdev-libs/libgusb: Version bump to 0.3.3 (diff)
downloadgentoo-37cdf73a4158483cffb10c9ea74cd787166902e6.tar.gz
gentoo-37cdf73a4158483cffb10c9ea74cd787166902e6.tar.bz2
gentoo-37cdf73a4158483cffb10c9ea74cd787166902e6.zip
dev-libs/libgweather: Version bump to 3.34.0
Closes: https://bugs.gentoo.org/691018 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/Manifest1
-rw-r--r--dev-libs/libgweather/files/3.34.0-tests-Add-another-duplicate.patch27
-rw-r--r--dev-libs/libgweather/libgweather-3.34.0.ebuild69
3 files changed, 97 insertions, 0 deletions
diff --git a/dev-libs/libgweather/Manifest b/dev-libs/libgweather/Manifest
index e5a2eaed32f1..f262ab963c3e 100644
--- a/dev-libs/libgweather/Manifest
+++ b/dev-libs/libgweather/Manifest
@@ -1 +1,2 @@
DIST libgweather-3.32.2.tar.xz 2716144 BLAKE2B 56bf66edde8293758f49c1ca14b47fb725f72a0202e95e6e1d1832c179fd9414d527827be5cb7daa17627abfbd1ac16d8d09dbdbbdcb24d62cc62c25a220c156 SHA512 61543e5eaf8c04605a91a6f47811b3a0ed2b04c2f50eae9b8d08a4e24904db4731748fa27a0863d2cdab5fde776ec55abe9fd9fb2a72c7bd546665d59957cb4d
+DIST libgweather-3.34.0.tar.xz 2725096 BLAKE2B af1034b905354aed433e3a5249305718b850f84dabcf3e96b9f9bcdda7dd78258ede0a9e82cab9b9d7f1b63d8e1a61bc3c83c1c18ec38790bc43c29fe98bb89d SHA512 44451837039965251d86f6f538c943a771ab1944d9190ddb2c6bdb34b3ed0e33756c537e84f24487fd5f28b107e8d3af05a6c20a68f83734ac26ff69a8bd0aba
diff --git a/dev-libs/libgweather/files/3.34.0-tests-Add-another-duplicate.patch b/dev-libs/libgweather/files/3.34.0-tests-Add-another-duplicate.patch
new file mode 100644
index 000000000000..29956e3f498f
--- /dev/null
+++ b/dev-libs/libgweather/files/3.34.0-tests-Add-another-duplicate.patch
@@ -0,0 +1,27 @@
+From ee246dc058098dee1709d76635e72db35efcef4e Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Wed, 20 Nov 2019 10:55:02 +0100
+Subject: [PATCH] tests: Add another duplicate
+
+$ wget -O- -q https://www.aviationweather.gov/docs/metar/stations.txt | grep KX26
+FL SEBASTIAN KX26 X26 27 49N 080 30W 6 X W 8 US
+FL VALKARIA AFS KX26 X26 27 49N 080 30W 6 X 8 US
+---
+ libgweather/test_libgweather.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libgweather/test_libgweather.c b/libgweather/test_libgweather.c
+index 1bfa3d4..8a21911 100644
+--- a/libgweather/test_libgweather.c
++++ b/libgweather/test_libgweather.c
+@@ -336,6 +336,7 @@ parse_metar_stations (const char *contents)
+ "KHQG",
+ "KOEL",
+ "KTQK",
++ "KX26",
+ NULL
+ };
+ if (g_strv_contains (known_duplicates, station)) {
+--
+2.24.1
+
diff --git a/dev-libs/libgweather/libgweather-3.34.0.ebuild b/dev-libs/libgweather/libgweather-3.34.0.ebuild
new file mode 100644
index 000000000000..c92f920bd9ec
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.34.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Location and timezone database and weather-lookup library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-16-2" # subslot = 3-(libgweather-3 soname suffix) w/ temporary -2 suffix for silent ABI break after 3.28 without soname bump as per distro-list
+
+IUSE="glade gtk-doc +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=x11-libs/gtk+-3.13.5:3[introspection?]
+ >=net-libs/libsoup-2.44:2.4
+ >=dev-libs/libxml2-2.6.0:2
+ sci-geosciences/geocode-glib
+ >=sys-libs/timezone-data-2010k
+
+ glade? ( >=dev-util/glade-3.16:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.11
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+PATCHES=(
+ "${FILESDIR}"/3.32.1-meson-tweaks.patch # Provide introspection optionality and don't build tests that aren't ran automatically
+ "${FILESDIR}"/${PV}-tests-Add-another-duplicate.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use glade glade_catalog)
+ $(meson_use vala enable_vala)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}