summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libisoburn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libisoburn')
-rw-r--r--dev-libs/libisoburn/Manifest2
-rw-r--r--dev-libs/libisoburn/libisoburn-1.3.8.ebuild66
-rw-r--r--dev-libs/libisoburn/libisoburn-1.4.0.ebuild66
-rw-r--r--dev-libs/libisoburn/metadata.xml20
4 files changed, 154 insertions, 0 deletions
diff --git a/dev-libs/libisoburn/Manifest b/dev-libs/libisoburn/Manifest
new file mode 100644
index 000000000000..5fbcad51f686
--- /dev/null
+++ b/dev-libs/libisoburn/Manifest
@@ -0,0 +1,2 @@
+DIST libisoburn-1.3.8.tar.gz 1429974 SHA256 b75c9a7f17faab5280ddc34ea6610c4e8bcf630762ee386d10bc52c4b50f6806 SHA512 369299e491a379e048038d8a46040feb628b6b9dfb6d6ffac01808b6814e6ca936bb7e4fe75f904ce755e9957011403a5d38bff9f37901086d284f5c1014deb7 WHIRLPOOL 3dc40ab34838bb3d79f0cbb08b16480106de16b2c8401859c52fa139eb8a555f4182402dacf51ee481ec8f490a33a2e09cfc4ec3ba63db9fc876854c80f4dd12
+DIST libisoburn-1.4.0.tar.gz 1453974 SHA256 c1d51ae7e4662f75caae4442071b8e1480efb8e80682a9f82c32a76f30ba6421 SHA512 d9fd1e4a6f8d6ec2dfe2eccdf2ba2e379232d5eb66e25940a8854f160ccd456fa384488acf466af51fb9662ecd5a774dc81fe0fbd03fb8e1b82118ee9d066d1c WHIRLPOOL 3db2740f2ed9dc4b872f0d424a231673a10d0bb8af88ac9cdc1272e3e738d5bdda43b57ac0e0e69a95ad4d73b97947bbb07b360b275ec57a53dbb75d6565004d
diff --git a/dev-libs/libisoburn/libisoburn-1.3.8.ebuild b/dev-libs/libisoburn/libisoburn-1.3.8.ebuild
new file mode 100644
index 000000000000..163d995bba48
--- /dev/null
+++ b/dev-libs/libisoburn/libisoburn-1.3.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Enables creation and expansion of ISO-9660 filesystems on all CD/DVD media supported by libburn"
+HOMEPAGE="http://libburnia-project.org/"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 x86"
+IUSE="acl cdio debug external-filters external-filters-setuid frontend-optional
+ launch-frontend launch-frontend-setuid libedit readline static-libs xattr zlib"
+
+REQUIRED_USE="frontend-optional? ( || ( launch-frontend launch-frontend-setuid ) )"
+
+RDEPEND=">=dev-libs/libburn-1.3.8
+ >=dev-libs/libisofs-1.3.8
+ readline? ( sys-libs/readline:0= )
+ !readline? ( libedit? ( dev-libs/libedit ) )
+ acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )
+ cdio? ( >=dev-libs/libcdio-0.83 )
+ launch-frontend? ( dev-lang/tcl:0 dev-lang/tk:0 )
+ launch-frontend-setuid? ( dev-lang/tcl:0 dev-lang/tk:0 )
+ frontend-optional? ( dev-tcltk/bwidget )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable readline libreadline) \
+ $(usex readline --disable-libedit $(use_enable libedit)) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ $(use_enable cdio libcdio) \
+ $(use_enable external-filters) \
+ $(use_enable external-filters-setuid) \
+ $(use_enable launch-frontend) \
+ $(use_enable launch-frontend-setuid) \
+ --disable-ldconfig-at-install \
+ --enable-pkg-check-modules \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.wiki,startup_file.txt}
+
+ docinto frontend
+ dodoc frontend/README-tcltk
+ docinto xorriso
+ dodoc xorriso/{changelog.txt,README_gnu_xorriso}
+ docinto xorriso/html
+
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libisoburn/libisoburn-1.4.0.ebuild b/dev-libs/libisoburn/libisoburn-1.4.0.ebuild
new file mode 100644
index 000000000000..750b8f14d591
--- /dev/null
+++ b/dev-libs/libisoburn/libisoburn-1.4.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Enables creation and expansion of ISO-9660 filesystems on all CD/DVD media supported by libburn"
+HOMEPAGE="http://libburnia-project.org/"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="acl cdio debug external-filters external-filters-setuid frontend-optional
+ launch-frontend launch-frontend-setuid libedit readline static-libs xattr zlib"
+
+REQUIRED_USE="frontend-optional? ( || ( launch-frontend launch-frontend-setuid ) )"
+
+RDEPEND=">=dev-libs/libburn-1.4.0
+ >=dev-libs/libisofs-1.4.0
+ readline? ( sys-libs/readline:0= )
+ !readline? ( libedit? ( dev-libs/libedit ) )
+ acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )
+ cdio? ( >=dev-libs/libcdio-0.83 )
+ launch-frontend? ( dev-lang/tcl:0 dev-lang/tk:0 )
+ launch-frontend-setuid? ( dev-lang/tcl:0 dev-lang/tk:0 )
+ frontend-optional? ( dev-tcltk/bwidget )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable readline libreadline) \
+ $(usex readline --disable-libedit $(use_enable libedit)) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ $(use_enable cdio libcdio) \
+ $(use_enable external-filters) \
+ $(use_enable external-filters-setuid) \
+ $(use_enable launch-frontend) \
+ $(use_enable launch-frontend-setuid) \
+ --disable-ldconfig-at-install \
+ --enable-pkg-check-modules \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.wiki,startup_file.txt}
+
+ docinto frontend
+ dodoc frontend/README-tcltk
+ docinto xorriso
+ dodoc xorriso/{changelog.txt,README_gnu_xorriso}
+ docinto xorriso/html
+
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libisoburn/metadata.xml b/dev-libs/libisoburn/metadata.xml
new file mode 100644
index 000000000000..8617e6515120
--- /dev/null
+++ b/dev-libs/libisoburn/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-optical</herd>
+<maintainer>
+<email>billie@gentoo.org</email>
+<name>Daniel Pielmeier</name>
+</maintainer>
+<use>
+<flag name='external-filters'>Allow the use of external processes as file content
+filters (Note: this is a potential security risk)</flag>
+<flag name='external-filters-setuid'>Also allow the use of external setuid
+processes as file content filters (Note: this is a potential security
+risk)</flag>
+<flag name='launch-frontend'>Enable the tcl gui for xorriso</flag>
+<flag name='launch-frontend-setuid'>Enable the tcl gui for xorriso under setuid</flag>
+<flag name='frontend-optional'>Use <pkg>dev-tcltk/bwidget</pkg> which is not strictly required for the frontend</flag>
+<flag name="cdio">Enable EXPERIMENTAL use of libcdio as system adapter</flag>
+</use>
+</pkgmetadata>