summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-05-12 16:20:07 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-05-12 17:01:14 -0400
commitb413908d3e83300091f75195fd02699deecb1005 (patch)
tree9c6fc8691d85b74be642b73181a45d205f583595 /dev-libs/libmateweather
parentmate-base/mate-desktop: Bump to 1.22.1 (diff)
downloadgentoo-b413908d3e83300091f75195fd02699deecb1005.tar.gz
gentoo-b413908d3e83300091f75195fd02699deecb1005.tar.bz2
gentoo-b413908d3e83300091f75195fd02699deecb1005.zip
dev-libs/libmateweather: Fix dependency versions
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'dev-libs/libmateweather')
-rw-r--r--dev-libs/libmateweather/libmateweather-1.22.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/libmateweather-1.22.0-r1.ebuild b/dev-libs/libmateweather/libmateweather-1.22.0-r1.ebuild
new file mode 100644
index 000000000000..2fef43535398
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.22.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.34:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.22:3"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ --disable-icon-update
+}