summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-05-25 20:53:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-26 10:19:15 +0200
commit8a6ec90c464889cef9478549f68b72ff0210eab4 (patch)
treea7fbb4a5b0534ab4f703d6a6f11832b67182cc10 /dev-libs/libretls/libretls-3.3.3.ebuild
parentdev-python/indexed_gzip: Bump to 1.6.1 (diff)
downloadgentoo-8a6ec90c464889cef9478549f68b72ff0210eab4.tar.gz
gentoo-8a6ec90c464889cef9478549f68b72ff0210eab4.tar.bz2
gentoo-8a6ec90c464889cef9478549f68b72ff0210eab4.zip
dev-libs/libretls: bump to 3.3.3
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Closes: https://github.com/gentoo/gentoo/pull/20989 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libretls/libretls-3.3.3.ebuild')
-rw-r--r--dev-libs/libretls/libretls-3.3.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libretls/libretls-3.3.3.ebuild b/dev-libs/libretls/libretls-3.3.3.ebuild
new file mode 100644
index 000000000000..1611d59e200f
--- /dev/null
+++ b/dev-libs/libretls/libretls-3.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Port of libtls from LibreSSL to OpenSSL"
+HOMEPAGE="https://git.causal.agency/libretls/about/"
+SRC_URI="https://causal.agency/libretls/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+DEPEND="dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-static
+ )
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}