summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-09 01:06:12 +0000
committerSam James <sam@gentoo.org>2022-01-09 01:06:33 +0000
commit4362cb069064cf42fca1e0d4929f44ffcd0af65a (patch)
treeecda792e0b7b82715782914313e96ccfdea60a04 /dev-libs/libsigsegv/libsigsegv-2.14.ebuild
parentsys-process/atop: add 2.7.1 (diff)
downloadgentoo-4362cb069064cf42fca1e0d4929f44ffcd0af65a.tar.gz
gentoo-4362cb069064cf42fca1e0d4929f44ffcd0af65a.tar.bz2
gentoo-4362cb069064cf42fca1e0d4929f44ffcd0af65a.zip
dev-libs/libsigsegv: add 2.14
Dropped test patch as passes fine on arm now. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libsigsegv/libsigsegv-2.14.ebuild')
-rw-r--r--dev-libs/libsigsegv/libsigsegv-2.14.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libsigsegv/libsigsegv-2.14.ebuild b/dev-libs/libsigsegv/libsigsegv-2.14.ebuild
new file mode 100644
index 000000000000..147508ab65ea
--- /dev/null
+++ b/dev-libs/libsigsegv/libsigsegv-2.14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library for handling page faults in user mode"
+HOMEPAGE="https://www.gnu.org/software/libsigsegv/"
+SRC_URI="mirror://gnu/libsigsegv/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-shared --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -f "${ED}/usr/$(get_libdir)"/*.la || die
+ dodoc AUTHORS ChangeLog* NEWS PORTING README
+}