summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2020-09-30 07:48:08 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2020-09-30 07:49:18 +0100
commit2ead77592d9bdc268e480b0b7f35c80465cf32ee (patch)
tree528b0b51654c04b8a382d7259a30c28d97164e8b /dev-libs/libstrophe
parentnet-libs/nodejs: Old (diff)
downloadgentoo-2ead77592d9bdc268e480b0b7f35c80465cf32ee.tar.gz
gentoo-2ead77592d9bdc268e480b0b7f35c80465cf32ee.tar.bz2
gentoo-2ead77592d9bdc268e480b0b7f35c80465cf32ee.zip
dev-libs/libstrophe: state explicitly that testing is enabled
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'dev-libs/libstrophe')
-rw-r--r--dev-libs/libstrophe/libstrophe-0.10.0.ebuild6
-rw-r--r--dev-libs/libstrophe/libstrophe-0.9.2.ebuild6
-rw-r--r--dev-libs/libstrophe/libstrophe-0.9.3.ebuild6
3 files changed, 18 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/libstrophe-0.10.0.ebuild b/dev-libs/libstrophe/libstrophe-0.10.0.ebuild
index be09401f2e96..5757ff621942 100644
--- a/dev-libs/libstrophe/libstrophe-0.10.0.ebuild
+++ b/dev-libs/libstrophe/libstrophe-0.10.0.ebuild
@@ -43,3 +43,9 @@ src_install() {
use doc && dodoc -r examples
find "${D}" -name '*.la' -o -name '*.a' -delete || die
}
+
+# Explicit src_test is there to document that the test suite is integrated and
+# is expected to pass. Please do not remove.
+src_test() {
+ emake check
+}
diff --git a/dev-libs/libstrophe/libstrophe-0.9.2.ebuild b/dev-libs/libstrophe/libstrophe-0.9.2.ebuild
index e370927cb139..c312bb04fe2b 100644
--- a/dev-libs/libstrophe/libstrophe-0.9.2.ebuild
+++ b/dev-libs/libstrophe/libstrophe-0.9.2.ebuild
@@ -44,3 +44,9 @@ src_install() {
use doc && dodoc -r examples
find "${D}" -name '*.la' -o -name '*.a' -delete || die
}
+
+# Explicit src_test is there to document that the test suite is integrated and
+# is expected to pass. Please do not remove.
+src_test() {
+ emake check
+}
diff --git a/dev-libs/libstrophe/libstrophe-0.9.3.ebuild b/dev-libs/libstrophe/libstrophe-0.9.3.ebuild
index be09401f2e96..5757ff621942 100644
--- a/dev-libs/libstrophe/libstrophe-0.9.3.ebuild
+++ b/dev-libs/libstrophe/libstrophe-0.9.3.ebuild
@@ -43,3 +43,9 @@ src_install() {
use doc && dodoc -r examples
find "${D}" -name '*.la' -o -name '*.a' -delete || die
}
+
+# Explicit src_test is there to document that the test suite is integrated and
+# is expected to pass. Please do not remove.
+src_test() {
+ emake check
+}