summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-05-20 17:54:23 -0500
committerJohannes Huber <johu@gentoo.org>2018-05-27 23:59:33 +0200
commit3a9ddc002c62c45e4b1d3945c6701fe355e9540d (patch)
tree7152ef6ccce55199b5871b2de95a2633587e86de /dev-libs/polylib
parentdev-util/bcc: Add check for CONFIG_FUNCTION_TRACER (diff)
downloadgentoo-3a9ddc002c62c45e4b1d3945c6701fe355e9540d.tar.gz
gentoo-3a9ddc002c62c45e4b1d3945c6701fe355e9540d.tar.bz2
gentoo-3a9ddc002c62c45e4b1d3945c6701fe355e9540d.zip
dev-libs/polylib: git-2->git-r3, EAPI 0->6
Also dropped unneeded patch (upstream code has this header included without need for the patch any longer.) eutils no longer required. Package-Manager: Portage-2.3.38, Repoman-2.3.9 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'dev-libs/polylib')
-rw-r--r--dev-libs/polylib/files/polylib-9999-headers.patch10
-rw-r--r--dev-libs/polylib/polylib-9999.ebuild16
2 files changed, 7 insertions, 19 deletions
diff --git a/dev-libs/polylib/files/polylib-9999-headers.patch b/dev-libs/polylib/files/polylib-9999-headers.patch
deleted file mode 100644
index 69b7b271a926..000000000000
--- a/dev-libs/polylib/files/polylib-9999-headers.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/applications/ehrhart_union.c
-+++ b/applications/ehrhart_union.c
-@@ -1,6 +1,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <stdlib.h>
-+#include <unistd.h>
-
- #include <polylib/polylib.h>
-
diff --git a/dev-libs/polylib/polylib-9999.ebuild b/dev-libs/polylib/polylib-9999.ebuild
index 63e1058b6a88..030fb2d71957 100644
--- a/dev-libs/polylib/polylib-9999.ebuild
+++ b/dev-libs/polylib/polylib-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=6
+
+inherit autotools git-r3
EGIT_REPO_URI="git://repo.or.cz/${PN}.git
http://repo.or.cz/r/${PN}.git"
-EGIT_BOOTSTRAP="eautoreconf && cd cln && eautoreconf"
-inherit git-2 autotools eutils
DESCRIPTION="ppl port of cloog"
HOMEPAGE="http://icps.u-strasbg.fr/polylib/"
@@ -16,15 +16,13 @@ SLOT="0"
KEYWORDS=""
IUSE=""
-src_unpack() {
- git-2_src_unpack
- cd "${S}"
- epatch "${FILESDIR}"/${P}-headers.patch
- # strip LDFLAGS from pkgconfig .pc file
+src_prepare() {
+ default
+ eautoreconf
sed -i '/Libs:/s:@LDFLAGS@::' configure
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
dodoc doc/Changes
}